View Full Version : C554e Cannot upgrade firmware beyond E4

Custom Search

09-18-2015, 09:25 PM
This box rolled in the door from a lease return with G00-E4 firmware, and working fine AFAIK. (Low meter scares me though). Tried to update to the latest, G00-K5, but it hangs before reaching the Firmware Update screen. Overnight, even. The SSD board has a green dot, 6.03, and the SSD Update Tool says it's good. After banging our heads together for a week, I decided to take baby steps, starting with E4. It took it as one normally would. Then GC2-E4, good. Now G9 - no way, hangs like before with two (or one and a half) bars on the screen.
Anyone have any ideas? I thought it might be related to this thread http://www.copytechnet.com/forums/konica-minolta/85556-e-series-rebooting-problem-whos-dealing.html?highlight=cannot+upgrade+firmware, but can't find anything really. Turned off the weekly timers, maxed sleep and power save, formatted hard drive occasionally, reseat memory. Somebody point me in a direction please.
I'm old, tired and hungry. See you after lunch.
I'm back, and realized I forgot to add above that the Management report shows HUGE counts on such things as 0206 (2,651) 0208 (2,366) 0214 (2,659) 11AX (2,641) 5102/3 (2,650), and various others. A clue for sure, as this unit shows 78 total. We don't know the history, but that count looks correct, as the unit is pristine. It has a KM sticker on it, so maybe this is a throw away? I'd still like some ideas, if you have any.

09-18-2015, 11:37 PM
I've had success in such situations by unplugging the hdd prior to doing the fw update.

If its there it is used in the process if its not, it isnt and it will update.

09-18-2015, 11:49 PM
Thanks for the tip, but in this case it doesn't seem to make a difference. Before unplugging the HDD, I Uninstalled it in Service Mode, though. Correct procedure?

09-18-2015, 11:53 PM
I just left it set to on and unplugged it.

I think your machine has serious issues.

Have you tried running the 6.05 ssd update in itself ? If that doesnt even work I would be leaning towards a failing SSD. Does everything test out in the power on diagnostic mode ?

09-19-2015, 12:23 AM
I ran the SSD Tool, and it says it doesn't need to be upgraded. I think it was 6.03. I don't see a 6.05 on KM for the C554e.
Yes, the Diagnostics show everything OK.
It perplexes me that it will take E4 and GC2-E4, but hangs on everything later. Reminds me of my old Moto Photon, locked at Gingerbread. If nothing else, I haven't tried downgrading and coming back up.

09-19-2015, 12:44 AM
6.05 has been around since mid last year - not sure where in the world you are but its definitely available.

09-19-2015, 12:56 AM
Where? I checked firmware, where I found the 6.03 tool.
We haven't placed many e models, and luckily haven't had any issues. You can bet we'll be checking everything in the field after this.

copier tech
09-19-2015, 10:44 AM
Just to add I've found this "e" series to be fussy on what USB drive you use, have you got a few others you could try?

09-19-2015, 02:41 PM
Yes, we've tried three or four different memory sticks, all that have worked previously on e models. I currently carry a 16 GB, but I reactivated a 4 GB just for this occasion. Again, the memory stick and machine will let me re-flash E4 firmware.
I am wondering what kind of issues arise when the proper procedure is not followed? For instance, when the firmware instructions require deleting the movie data, etc., before upgrading, and what happens when the Function Version level is set improperly? Originally, the Version showed 5 on this unit, yet Soft Switch 25 was set at 50, which should have been Version 6, correct? Function Version 6 is not valid on E4.
I have considered that someone has swapped boards on this machine, and the erroneous data is resulting from a mismatch, but then, how is it even operating? KM's get very angry when the proper procedure is not followed, in my experience that is.
So far I've researched base firmware, but will decide Monday AM to either down-grade or try special firmware. I have a feeling it will take any special E4. I'll be looking for SSD 6.05 also. (I briefly considered setting up ISW, which I have done for a C203 or similar, but I've regained my senses.)

copier tech
09-19-2015, 04:09 PM
I guess you dont know the history of this machine so yes maybe boards have been swapped.

Have you tried a system reset?

Do you actually need to update the fw? If not maybe leave it alone as it's working, you may find when later fw is released you can update it.

09-20-2015, 03:10 PM
See if your ssd board has a id of 14xxxx means it has ver6.05, the old ver6.03 has 13xxxx id on the board

see attached


09-21-2015, 08:28 PM
So, I verified SSD Board is at 6.03. Downgraded to C8 which went OK (Version 2). Upgraded back to E4 OK. Set to Version 5. Attempted G9, but it wouldn't even make it to the Firmware screen, just one short bar and a ghost of a second bar. Formatted HDD. No change for G9 upgrade. Just installed new HDD and attempting G9 again.
It's been suggested I try LK-101 FW. Any thoughts or suggestions appreciated.
By the way, thanks for the suggestions so far.

09-21-2015, 09:58 PM
Please take my advise with a pinch of salt.

Since you are confused by the meter counts maybe board change happened along the way. Have a closer look if it allows you to do the update with G20-G9 firmware with 2GB Stick and check which machine & type you have selected!! Be patient !!I waited once 35minutes for one similar case.
I have feeling you don't have either version up firmware loaded (GD4-A9) or G20-A9 which is why you might be stuck on the E4 if different MFPB was put in machine with C8 loaded in previous machine. Although it doesn't make much sense as version up firmware starts before C8. I'd try 2GB stick FAT 32 with G20-G9 directly to the root and just one firmware at a time on the stick. If it takes it in, then you are fine and can upgrade SSD 6.05m after. If it doesn't take it then I'd go and downgrade with the version up firmware G20-A9 first then SSD ver 6.05m. Then G20-E4,G9,K2.

Can someone enlighten here with the experience of downgrading please from above version up firmware i.e E4,G9 to version up firmware A9 ??!!

To confuse you a bit more there is SSD 6.02n and 6.03m and then 6.05m..Check which one you have! As you can't go from 6.02n to 6.05m (which might be your case since "G9 contains 6.05m"!)


From my experience G20-G9 Contains 6.05m and was told that the G20-K2 has it as well. The G20-G9 did roll SSD from ver6.03m to 6.05m but I had the version up firmware G20-A9 or newer(A5C10Y0-F000-GD4-A9) installed in between SSD 6.03m and G20-E4.

Phew kamikaze.. I just hope I shed at least some light in to your darkness.

EDIT: Apologies,,just re-read your last post and you confirmed that you have 6.03m

Try the 6.05m first then the G20-G9

09-21-2015, 11:45 PM
habik, thanks.
First, All I can come up with is a 4 GB stick, and I have used this on a C454e today, in fact. One firmware at a time on the stick is all I've done here - it's much less confusing that way, since I've been trying so many different variations.
I noticed you are talking only about the G20-xx FW. Is there a reason I don't want to stick with the non-Ioption in this upgrade effort, since I don't need it? I am trying, G20-G9 currently, because I'm running out of ideas, but wondered if there is some kind of magic in the G20 versions?
Also, I do not see GD4-A9 on the KM site, nor the A5C10Y0-F000-G00-A9-05--SSD-FW-Ver6.05m. Where are they hiding that stuff? Can the SSD bd even be downgraded?
BTW, G20-G9 is not working either. Next up, G20-A9 & SSD.

09-22-2015, 05:34 PM
My apologies guys... reading back through this thread I see where I said "I verified the SSD bd was 6.03." If I could read AND write at the same time, I would have corrected that to read "6.05."
Doesn't matter, we're shipping this back. Thank you all for your input!

09-22-2015, 05:56 PM
My apologies guys... reading back through this thread I see where I said "I verified the SSD bd was 6.03." If I could read AND write at the same time, I would have corrected that to read "6.05."
Doesn't matter, we're shipping this back. Thank you all for your input!

:) That is a solution as well. Would be interesting to find what the problem was. Think EarthKMtech was probably right that the SSD is on its last legs :)

I am not sure if there is a Downgrade firmware G00-00 for the e-series, but that could possibly be last option. Question is what would happen to the MFPB?

Custom Search