Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26
  1. #21
    Trusted Tech 50+ Posts
    Join Date
    Mar 2017
    Location
    bloemfontein
    Posts
    84
    Rep Power
    4

    Re: Canon Adv C5045 - blank screen

    hi..

    can i ask what you have already tried and changed..im getting abit confused.

    as i understand you have changed

    main 1+2
    hdd
    power supply

    have you checked fuses on your ac driver pcb?
    dimms can also cause screen to no come on as no memory to start up boot.

    if it was HDD screen would still come on.either a background light or boot bar.

  2. #22
    Technician RobertOB's Avatar
    Join Date
    Dec 2018
    Location
    Belleville
    Posts
    23
    Rep Power
    1

    Re: Canon Adv C5045 - blank screen

    Any update to this, I keep getting bugged by the other guys in the shop as to what fixed this.

  3. #23
    Senior Tech 500+ Posts kuby's Avatar
    Join Date
    Oct 2007
    Location
    Texas
    Posts
    802
    Rep Power
    33

    Re: Canon Adv C5045 - blank screen

    Nothing fixed it. Finally after hours and hours and $$$$ gave up. Sold them another machine.

  4. #24
    Junior Member
    Join Date
    Feb 2019
    Location
    Hammond
    Posts
    5
    Rep Power
    0

    Re: Canon Adv C5045 - blank screen

    Quote Originally Posted by guitar9199 View Post
    Have you tried booting it into service mode?

    How do you boot into service mode on Canon C5045?

  5. #25
    Service Manager 10,000+ Posts
    Canon Adv C5045 - blank screen

    teckat's Avatar
    Join Date
    Jan 2010
    Location
    VA
    Posts
    15,785
    Rep Power
    226

    Re: Canon Adv C5045 - blank screen

    Quote Originally Posted by cobragirl View Post
    How do you boot into service mode on Canon C5045?

    Service Mode level 1 and 2 on the imageRUNNER ADVANCE





    To go to Service Mode Classic Level 1 follow the steps bellow:


    1) Select Settings/Registration


    2) Press 2 & 8 at the same time


    3) Select Settings/Registration


    To go to Service Mode Level 2, go to Service Mode level 1 and then:


    1) Select Settings/Registration.


    2) Select 2.
    ==================================================

    or


    Go to Service Mode > follow the steps bellow:


    1) Select Settings/Registration


    2) Press 2 & 8 at the same time


    3) Select Settings/Registration


    4) Select Mode List


    5) Select Copier


    6) Select Option


    7) Select FNC-SW


    8) Highlight [Level 1] to toggle between level 1 and level 2.
    **Knowledge is time consuming, exhausting and costly for a trained Tech.**

  6. #26
    Junior Member
    Join Date
    Feb 2019
    Location
    Hammond
    Posts
    5
    Rep Power
    0

    Re: Canon Adv C5045 - blank screen

    [QUOTE=teckat;725775]
    Service Mode level 1 and 2 on the imageRUNNER ADVANCE





    To go to Service Mode Classic Level 1 follow the steps bellow:


    1) Select Settings/Registration


    2) Press 2 & 8 at the same time


    3) Select Settings/Registration



    THANK YOU... I was using the asterisk key instead of the Settings/Registrations key. :-)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here