Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1
    Junior Member
    Join Date
    Jul 2019
    Location
    Barcelona
    Posts
    6
    Rep Power
    0

    Canon iRC2880i Scan to Email problem (SSL protocol?)

    Hello,

    First of all, I’m new here. Greetings to everyone. I found this forum while googling the only copier problem I’m not able to fix by myself and you’re my last hope now.

    I have an old Canon iRC2880i photocopier that I used a lot in the past (2012 – 2013). However, due to some incompatibilities with my former ISP router, I couldn’t use most of the network features and I quit using it. At that time, I was able to use network printing, scanning and scan to email functions.

    Now, I have some projects in mind and I decided to clean it and get it back to work.
    I have successfully configured the network printing and scanning functions but the Scan to Email seems to fail. I read dozens of threads in this forum about “scan to email” issues and I explored many options… but nothing has worked for me after 4 days and more than 100 emails trying (not exaggerating).


    Here you can find my current configuration:

    email1.jpgemail2.jpg

    Receive SMTP: OFF POP: OFF
    SMTP server: smtp.gmail.com
    Email address: myaddress@gmail.com
    POP Auth before sending: OFF
    SMTP Authentication: ON
    User: myaddress@gmail.com
    Password: ********
    Allow SSL (Send): ON
    Allow SSL (Receive): Always SSL
    SMTPTXPN: Port 465 (Using 2*8, level 2 options)




    Additional information:


    • I tried Port 587 with SSL and Ports 25, 587 and 465 without SSL with no results.
    • “Two-step authentication” is disabled and “less secure apps” is enabled.
    • I tried the DNS provided by my ISP and also the Google Public DNS (8.8.8.8 and 8.8.4.4) with no results.
    • I set the right time, date and GMT. No success.
    • I tried different email servers (outlook, gmx, hushmail…), alternative Gmail SMTP domains and even input the IP address in the SMTP server box but nothing seems to work.
    • Email settings were specified in the machine, not via RUI.
    • I can send emails with SMTP using a SMTP diagnosis tool in my desktop computer using the configuration above. Therefore, I discard a problem in my router, ISP or email server.
    • I can ping 8.8.8.8 and other IP addresses in the photocopier.
    • I get error #753 when the combination SSL-Port is wrong and #801 when is correct.




    A moment ago though I discovered a possible problem. I tried RUI with SSL enabled… and it won’t connect. An error message appears:

    - Mozilla Firefox: SSL_ERROR_PROTOCOL_VERSION_ALERT
    - Google Chrome: ERR_SSL_VERSION_OR_CIPHER_MISMATCH
    - IE: Eternally loading page


    I checked the certificate of the machine and I found out that Default Key expired in 2014! Then, I created a new Default Key with expiration date 2030 and deleted the previous one… but the problem persists. Did I do it right?

    IMG_0193.jpgIMG_0194.jpg




    I believe there is something to do with the SSL certificate or maybe the firmware. According to Canon webpage there is no firmware update for my machine… but the fact of being so old makes me think the opposite. How do I know I have the latest firmware? Could this be the source of my problem?






    Thanks in advance for reading. I appreciate any kind of help. I’m out of ideas now.

  2. #2
    Junior Member
    Join Date
    Jul 2019
    Location
    Barcelona
    Posts
    6
    Rep Power
    0

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    Anyone?

  3. #3
    Service Manager 2,500+ Posts
    Canon iRC2880i Scan to Email problem (SSL protocol?)

    Phil B.'s Avatar
    Join Date
    Jul 2016
    Location
    Raleigh NC
    Posts
    4,761
    Rep Power
    77

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    Quote Originally Posted by Vendimia View Post
    Anyone?
    please search the site for "scan to email" or "smb scan"

    this subject has been covered Ad nauseam ...

    some copiers have had firmware updates to fix this issue...

    others due to AGE the companies refuse to update their firmware.

  4. #4
    Service Manager 2,500+ Posts
    Canon iRC2880i Scan to Email problem (SSL protocol?)

    copier tech's Avatar
    Join Date
    Jan 2014
    Location
    London
    Posts
    3,535
    Rep Power
    66

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    You need to update the firmware to enable SSL needed to scan via gmail.
    Let us eat, drink, and be merry, because tomorrow we may die!

    www.copierfirmware.co.uk

  5. #5
    Junior Member
    Join Date
    Jul 2019
    Location
    Barcelona
    Posts
    6
    Rep Power
    0

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    Quote Originally Posted by copier tech View Post
    You need to update the firmware to enable SSL needed to scan via gmail.
    Thanks for your reply.


    The only firmware I have is the original Canon CD I found with the photocopier (dated 2001). If there were any updates before the copier came to my hand, there is no way to know.

    In addition, according to Canon, there are no firmware updates for this model:

    imageRUNNER C2880 - Support - Download drivers, software and manuals - Canon UK
    Firmware Update - Canon Europe


    Maybe it's a faulty model or too old for firmware updates. Shoud I give up?

  6. #6
    Technician
    Join Date
    Oct 2018
    Posts
    44
    Rep Power
    2

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    There is no Firmware on the CD.
    Firmware is not avaible online, you need the SST and the Firmware.

  7. #7
    Service Manager 2,500+ Posts
    Canon iRC2880i Scan to Email problem (SSL protocol?)

    copier tech's Avatar
    Join Date
    Jan 2014
    Location
    London
    Posts
    3,535
    Rep Power
    66

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    Quote Originally Posted by disamm View Post
    There is no Firmware on the CD.
    Firmware is not avaible online, you need the SST and the Firmware.
    The CD you have is simply a driver.

    You need the firmware, this is a bit like a PC operating system.

    Its only available to authorised personnel.
    Let us eat, drink, and be merry, because tomorrow we may die!

    www.copierfirmware.co.uk

  8. #8
    Junior Member
    Join Date
    Jul 2019
    Location
    Barcelona
    Posts
    6
    Rep Power
    0

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    Quote Originally Posted by copier tech View Post
    The CD you have is simply a driver.

    You need the firmware, this is a bit like a PC operating system.

    Its only available to authorised personnel.

    I think the CD is something more than just a driver. There are folders named “BootROM” or “HDD”, which content I think are specifically meant for the copier (according to file extensions). Anyway, I’m sure it’s not what I need now.

    Isn’t there any possible way I can proceed on my own?

    I’m not a technician but I’m willing to learn and contribute to its functioning. I’m feeling as if I’m restoring an old valuable machine. It’s becoming personal, actually.

    Please help

  9. #9
    Field Supervisor 500+ Posts
    Join Date
    Apr 2010
    Location
    the west
    Posts
    658
    Rep Power
    28

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    The process and tools needed are used by and available for trained techs only. Call one. Or, risk turning your machine into a big plant stand.

  10. #10
    Trusted Tech 50+ Posts nicknt82's Avatar
    Join Date
    Nov 2011
    Location
    hochiminh
    Posts
    56
    Rep Power
    16

    Re: Canon iRC2880i Scan to Email problem (SSL protocol?)

    Quote Originally Posted by Vendimia View Post
    Hello,

    First of all, I’m new here. Greetings to everyone. I found this forum while googling the only copier problem I’m not able to fix by myself and you’re my last hope now.

    I have an old Canon iRC2880i photocopier that I used a lot in the past (2012 – 2013). However, due to some incompatibilities with my former ISP router, I couldn’t use most of the network features and I quit using it. At that time, I was able to use network printing, scanning and scan to email functions.

    Now, I have some projects in mind and I decided to clean it and get it back to work.
    I have successfully configured the network printing and scanning functions but the Scan to Email seems to fail. I read dozens of threads in this forum about “scan to email” issues and I explored many options… but nothing has worked for me after 4 days and more than 100 emails trying (not exaggerating).


    Here you can find my current configuration:

    email1.jpgemail2.jpg

    Receive SMTP: OFF POP: OFF
    SMTP server: smtp.gmail.com
    Email address: myaddress@gmail.com
    POP Auth before sending: OFF
    SMTP Authentication: ON
    User: myaddress@gmail.com
    Password: ********
    Allow SSL (Send): ON
    Allow SSL (Receive): Always SSL
    SMTPTXPN: Port 465 (Using 2*8, level 2 options)




    Additional information:


    • I tried Port 587 with SSL and Ports 25, 587 and 465 without SSL with no results.
    • “Two-step authentication” is disabled and “less secure apps” is enabled.
    • I tried the DNS provided by my ISP and also the Google Public DNS (8.8.8.8 and 8.8.4.4) with no results.
    • I set the right time, date and GMT. No success.
    • I tried different email servers (outlook, gmx, hushmail…), alternative Gmail SMTP domains and even input the IP address in the SMTP server box but nothing seems to work.
    • Email settings were specified in the machine, not via RUI.
    • I can send emails with SMTP using a SMTP diagnosis tool in my desktop computer using the configuration above. Therefore, I discard a problem in my router, ISP or email server.
    • I can ping 8.8.8.8 and other IP addresses in the photocopier.
    • I get error #753 when the combination SSL-Port is wrong and #801 when is correct.




    A moment ago though I discovered a possible problem. I tried RUI with SSL enabled… and it won’t connect. An error message appears:

    - Mozilla Firefox: SSL_ERROR_PROTOCOL_VERSION_ALERT
    - Google Chrome: ERR_SSL_VERSION_OR_CIPHER_MISMATCH
    - IE: Eternally loading page


    I checked the certificate of the machine and I found out that Default Key expired in 2014! Then, I created a new Default Key with expiration date 2030 and deleted the previous one… but the problem persists. Did I do it right?

    IMG_0193.jpgIMG_0194.jpg




    I believe there is something to do with the SSL certificate or maybe the firmware. According to Canon webpage there is no firmware update for my machine… but the fact of being so old makes me think the opposite. How do I know I have the latest firmware? Could this be the source of my problem?


    Thanks in advance for reading. I appreciate any kind of help. I’m out of ideas now.

    Do you ping 64.233.189.108 and 8.8.8.8 from Photocopier? That will check the machine can out internet or can connect to smtp.gmail.com

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here