Results 1 to 7 of 7
  1. #1
    Just a tech 250+ Posts keithxxiii's Avatar
    Join Date
    Nov 2014
    Posts
    343
    Rep Power
    15

    The Handle is invalid

    Hi,

    Users randomly gets the error "the handle is invalid". It is a shared printer BTW, and if affected user tries to login to a different pc, it works. Printer is installed thru GP. Been searching articles on the internet and is pointing to outdated printer drivers. The server is 2012 R2 with full updates, PCL driver has been updated as well. I'm trying to convince the IT to create a new Print server since it is a VM and is easy for them to create it but the gents doesn't want to buy my reason.
    Has anybody faced the same error before? How'd you fixed it?
    Untitled.jpg
    TIA
    Aye! Cut the crap

  2. #2
    Senior Tech 250+ Posts JLSam's Avatar
    Join Date
    Jun 2015
    Location
    Los Angeles
    Posts
    270
    Rep Power
    16

    Re: The Handle is invalid

    While i personally have never seen this error. I can tell you that I've seen alot of funky printer driver issues solely because of a bad port setting. Even though it's PCL6 the port is under a hostname, or wsd. Id double check to make sure that its under standard tcp/ip.

    My two cents.

    Sent from my ONEPLUS A5000 using Tapatalk

  3. #3
    Just a tech 250+ Posts keithxxiii's Avatar
    Join Date
    Nov 2014
    Posts
    343
    Rep Power
    15

    Re: The Handle is invalid

    Quote Originally Posted by JLSam View Post
    While i personally have never seen this error. I can tell you that I've seen alot of funky printer driver issues solely because of a bad port setting. Even though it's PCL6 the port is under a hostname, or wsd. Id double check to make sure that its under standard tcp/ip.

    My two cents.

    Sent from my ONEPLUS A5000 using Tapatalk
    Thanks for your input, we make sure that WSD is disabled as part of our installation checklist. Aside from that, printing directly from the PC using TCP/IP (local printer installation) works fine.
    Aye! Cut the crap

  4. #4
    Field Supervisor 500+ Posts tsbservice's Avatar
    Join Date
    May 2007
    Posts
    801
    Rep Power
    41

    Re: The Handle is invalid

    Didn't see it personally, but you may want to check last post about rendering print jobs of this thread:
    https://social.technet.microsoft.com...winserverprint
    A tree is known by its fruit, a man by his deeds. A good deed is never lost, he who sows courtesy, reaps friendship, and he who plants kindness gathers love.

  5. #5
    Senior Tech. 2,500+ Posts NeoMatrix's Avatar
    Join Date
    Nov 2010
    Location
    Sunshine State QLD.
    Posts
    3,193
    Rep Power
    80

    Re: The Handle is invalid

    "Invalid Handle" sounds like a server O/S fault.
    A thread message sent inside the operating system software did not link to allocated thread/window.

    A stab in the dark. I'd check the O/S is not getting memory allocation errors coming from RAM chip dynamic hardware fault.

    Maybe a server Operating System reset?
    Reinstall the printer drivers...?
    What if we could count the stars... , what number would you stop at...?"
    [Exchange manual acquisitions, PM's CTN members only. ]
    [] |N | | o | M | Δ | t | π | | x | []

  6. #6
    Field Supervisor 500+ Posts
    The Handle is invalid


    Join Date
    May 2009
    Location
    Concord, NH
    Posts
    584
    Rep Power
    31

    Re: The Handle is invalid

    Quote Originally Posted by keithxxiii View Post
    Thanks for your input, we make sure that WSD is disabled as part of our installation checklist. Aside from that, printing directly from the PC using TCP/IP (local printer installation) works fine.
    Since you state that installing the print driver locally to the unit works fine, the driver setup on the server is the problem. Had a situation two days ago on a new install for a customer with 200+ of our units that would not print envelopes, everything else printed fine, printing envelopes from a local install of the driver to the unit worked. It took two hours and attaching a new test unit to convince the network IT people their network print queue was the problem. If a local install of the print driver works it points directly to the network print driver installation.

  7. #7
    Just a tech 250+ Posts keithxxiii's Avatar
    Join Date
    Nov 2014
    Posts
    343
    Rep Power
    15

    Re: The Handle is invalid

    Just an update guys,

    IT has assigned a new Print Server, which then will be the same hostname and IP. I just exported the printers and restored to the new server. It seems to be working fine now since it has been running for more than 5 days without reported issue.
    I still would want to know where the problem is coming from but i leave it to the IT.
    anyways, thanks for all your inputs.
    Aye! Cut the crap

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here