Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: B554e J30-03

  1. #11
    Senior Tech 100+ Posts Brett GS's Avatar
    Join Date
    Jun 2013
    Location
    Johannesburg
    Posts
    109
    Rep Power
    13

    Re: B554e J30-03

    Quote Originally Posted by blackcat4866 View Post
    There are two clutches in that drive pack CL6 and CL8. They're identical. Are you sure it was CL8? =^..^=
    Going back tomorow.
    Will check and report back.
    Tech replaced the top clutch.

  2. #12
    Senior Tech 250+ Posts tsbservice's Avatar
    Join Date
    May 2007
    Posts
    380
    Rep Power
    28

    Re: B554e J30-03

    Wrong picture. There is only one clutch in this drive.


    554e.jpg
    A tree is known by its fruit, a man by his deeds. A good deed is never lost, he who sows courtesy, reaps friendship, and he who plants kindness gathers love.

  3. #13
    Junior Member
    Join Date
    Oct 2018
    Location
    Little Falls NJ
    Posts
    2
    Rep Power
    0

    Re: B554e J30-03

    You are on the right track , In My case Biz 454e the IC chip was burned you could see the burn on outside of the chip probably from fuser drive clutch over heating you always see rusty clutch dust when opening right side door looking at rear upper section near drive clutch. location on PRCB was IC 38 for 454e may be the same for 554e ?

  4. #14
    Senior Tech 100+ Posts CopierNerd's Avatar
    Join Date
    Feb 2015
    Posts
    112
    Rep Power
    10

    Re: B554e J30-03

    Quote Originally Posted by Brett GS View Post
    Hi all
    Got a B554e jamming (j30-03).
    Paper gets into the fuser and stops.
    So far replace fuser drive/exit clutch,reg unit,exit unit,duplex unit,fuser,complet pickup unit,fuser drive motor and 2nd transfer door,checked all the icp's on PCRB but still no luck.
    Machine is on 400k.
    Am i missing something
    J30-03, Paper jams at 11. Paper gets into fuser and stops. How much it gets in? if you have replaced all things mentioned then you should check transfer belt drive. Transfer belt is not rotating. You are saying you have checked image registration is fine. I dont think so. I believe no image transfer. Faced same fault today.

  5. #15
    Senior Tech 100+ Posts Brett GS's Avatar
    Join Date
    Jun 2013
    Location
    Johannesburg
    Posts
    109
    Rep Power
    13

    Re: B554e J30-03

    Hi guys
    Turned out being the printer control board being faulty.
    Thanks all for the input.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •