Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 8 of 8

Thread: BH 750 firmware

  1. #1
    Walter 100+ Posts
    Join Date
    Jun 2009
    Location
    Sunny Isles
    Posts
    142
    Rep Power
    19

    BH 750 firmware

    Hey all. Got a 750 that's not warming up nor coding out even after 5 min. all is active on op. panel. Heat lamps not turning on at all. Thanks. I got newest firmware on a CF card can I put it into sys board & turn it on. If anything else I need to please let me know

    Last edited by SKTeK315; 02-15-2011 at 09:14 PM. Reason: Added

  2. #2
    Technician longshot0127's Avatar
    Join Date
    Dec 2009
    Location
    Midland, Tx
    Posts
    10
    Rep Power
    17
    The BH 750 firmware is upgraded through usb flash drive. The firmware has to be loaded on to the root of the drive in keep in the correct file name as downloaded. From service mode on the machine you have to enter to ISW and locate the bin file on the usb drive.


  3. #3
    Walter 100+ Posts
    Join Date
    Jun 2009
    Location
    Sunny Isles
    Posts
    142
    Rep Power
    19
    This is good. Tell me more. Please. What do I need & how to do it if you can. Maybe you can shed some light on this. 750 threw a c4707. Changed laser but not before I changed 1st image board with 750 orig NVram & CF cards. Then I installed the main board. Now it's a set from a 600. No change at all in condition of my 750. I finally changed the laser unit. I put all boards back into 750. It's back to itself.it came back up but never to ready. Normal ready screen. Fuser lamps do not come on. Waited 5 min at a time. No code. What's up with this thing.


  4. #4
    Senior Tech 250+ Posts
    Join Date
    May 2007
    Location
    Wake Forest, NC
    Posts
    313
    Rep Power
    26

    750 firmware

    I would recheck all the connectors on the boards you replaced. You might have missed one.


  5. #5
    Walter 100+ Posts
    Join Date
    Jun 2009
    Location
    Sunny Isles
    Posts
    142
    Rep Power
    19
    That's what I'm thinking but I've cycled 3 times already. Today was the 3rd time. I'll check again & try a different fuser


  6. #6
    Field Service Manager 1,000+ Posts
    BH 750 firmware

    pepper38_cnd's Avatar
    Join Date
    Aug 2005
    Location
    Windsor, ON Canada
    Posts
    1,077
    Rep Power
    39
    You may be completely off track. A simple thing like a dirty D Max sensor in the Drum Carriage will cause these machines to hang or not become ready without coding.

    Online Store is closed. Chip resetting is a thing of the past! Thank you to all my past customers.
    Now into Ip TV KODI Boxes

  7. #7
    Technician
    Join Date
    Nov 2007
    Posts
    14
    Rep Power
    21
    The same symptoms can occur if the sensor that detects the lever to unlock the ADU is knocked off or the plastic piece is broken. Most probably happens when customer forces the handle to rotate while in the lock position.


  8. #8
    Field Supervisor 2,500+ Posts
    Join Date
    Jun 2009
    Posts
    3,020
    Rep Power
    84
    Quote Originally Posted by SKTeK315 View Post
    Hey all. Got a 750 that's not warming up nor coding out even after 5 min. all is active on op. panel. Heat lamps not turning on at all. Thanks. I got newest firmware on a CF card can I put it into sys board & turn it on. If anything else I need to please let me know

    I think he has posted what has caused his problem...you screwed up the firmware by throwing it on the CF card and powering up. You are going to have to go back to base firmware (this you can put on card and power up MFP), then you must use USB ISW to upgrade MFP from ver 10 (base) to ver 13 then ver 20. If you have access to KM knowledge base, search "base firmware Bizhub 750" and you should find the correct procedure to fix this. Emujo


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •