Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1
    Senior Tech 100+ Posts
    Join Date
    Jan 2012
    Location
    EU,Slovenia
    Posts
    106
    Rep Power
    13

    MP C3500 Magenta drum problem

    Dot on magenta drum apeared.I changed the drum..good for awhile...apeared again.
    Changed the whole unit with developer and everything...good for awhile...apeared again.
    Changed the drum again and whole transfer belt unit(on inspection the old one looked fine) ...good for awhile...apeared again.

    The dot is always visable on the drum...looks like mechanical defect...like little cut...

    Its always only on magenta drum...

    Any suggestions?

    THANX!!!




  2. #2
    Service Manager 2,500+ Posts TonerMunkeh's Avatar
    Join Date
    Apr 2008
    Posts
    3,205
    Rep Power
    72

    Re: MP C3500 Magenta drum problem

    Is the dot always in the same place when you replace the drum?

    Computers are serious tools, Michael!

  3. #3
    Senior Tech 100+ Posts
    Join Date
    Jan 2012
    Location
    EU,Slovenia
    Posts
    106
    Rep Power
    13

    Re: MP C3500 Magenta drum problem

    No.
    Sometimes also multiple dots....


  4. #4
    Trusted Tech 50+ Posts HitMan's Avatar
    Join Date
    Aug 2015
    Location
    Edinburgh
    Posts
    77
    Rep Power
    5

    magenta drum chip

    Maybe check that the other units aren't spreading any dirt through the machine. Maybe vac out the drum units before magenta. Make sure there's nothing stuck on the magnetic roller in the development unit. Could be hard toner or even a staple?


  5. #5
    Service Manager 2,500+ Posts TonerMunkeh's Avatar
    Join Date
    Apr 2008
    Posts
    3,205
    Rep Power
    72

    Re: MP C3500 Magenta drum problem

    With how it's blown out it looks like an arc mark. Are there any ITB related SC codes?

    Computers are serious tools, Michael!

  6. #6
    Trusted Tech 50+ Posts HitMan's Avatar
    Join Date
    Aug 2015
    Location
    Edinburgh
    Posts
    77
    Rep Power
    5

    Re: MP C3500 Magenta drum problem

    I know you said you replaced the complete unit but what's the condition of the charge roller? Any marks on the roller also?


  7. #7
    Senior Tech 100+ Posts
    Join Date
    Jan 2012
    Location
    EU,Slovenia
    Posts
    106
    Rep Power
    13

    Re: MP C3500 Magenta drum problem

    Charge roller is good,no damage
    No SC codes
    What is arc mark?


  8. #8
    Trusted Tech 50+ Posts HitMan's Avatar
    Join Date
    Aug 2015
    Location
    Edinburgh
    Posts
    77
    Rep Power
    5
    Ark would be from a charge wire but these machines have charge rollers.


  9. #9
    Retired 5,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    7,057
    Rep Power
    152

    Re: MP C3500 Magenta drum problem

    Have seen this frequently when using cheap toner. Use only Genuine Ricoh.

    Also, toner density could be too high. If you are using Genuine Ricoh, make the adjustments in the attached file.Service Program (SP) Settings.pdf


  10. #10
    Trusted Tech 50+ Posts HitMan's Avatar
    Join Date
    Aug 2015
    Location
    Edinburgh
    Posts
    77
    Rep Power
    5

    Nightmare fault :(

    What about the drive gears for the magenta pcu? The ones the pcu engages with. The white gears at the back of the machine next to the rj45 type connector for the pcu. Could it be that the recycling unit at the pcu cannot get rid of the toner?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here