Thanks Thanks:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Technician jimmycabral's Avatar
    Join Date
    Jun 2016
    Location
    Miami
    Posts
    33
    Rep Power
    3

    Light Image - Ricoh Pro 907Ex

    I need any input for this problem, I have Pro 907Ex have light image problem.I noticed it have issue adding toner to the developer even hopper is full. I tried to " Force Toner Supply but it don't work. My vref is 3.54 and Vt is 3.68. Developer change recently and not reach more than 100k. Drum is used but it just 600K copies.

    thanks

    jimmy


  2. #2
    Field Supervisor 500+ Posts
    Light Image - Ricoh Pro 907Ex

    totoro's Avatar
    Join Date
    Apr 2008
    Posts
    520
    Rep Power
    27

    Re: Light Image - Ricoh Pro 907Ex

    Pull out the developer unit, cheat the front interlocks , run forced toner supply and look in the back where the developer unit would connect at the back of the machine. There are 2 motor couplings that should turn. If the hopper is full and there is no toner in the developer unit then I think it would be the top coupling for the toner hopper toner feed paddle. D059 3261 Pump: Toner Supply: Ass'y. Hope that helps

    Totoro

  3. #3
    Technician jimmycabral's Avatar
    Join Date
    Jun 2016
    Location
    Miami
    Posts
    33
    Rep Power
    3

    Re: Light Image - Ricoh Pro 907Ex

    Thanks, you give me nice idea....i'll check it...
    jim


  4. #4
    Retired 5,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    6,870
    Rep Power
    148

    Re: Light Image - Ricoh Pro 907Ex

    I had the motor that drives the dispenser in the hopper go bad. Also check that the dispensing holes on the bottom of the hopper are not clogged.


  5. #5
    Master Of The Obvious 10,000+ Posts
    Light Image - Ricoh Pro 907Ex

    blackcat4866's Avatar
    Join Date
    Jul 2007
    Location
    Lapeer, Michigan
    Posts
    15,203
    Rep Power
    245

    Re: Light Image - Ricoh Pro 907Ex

    I had an e Studio 905 (rebadged Ricoh 907) undertoning and giving SC495 codes. It turned out to be the toner pump. Over 600 copies it transitioned from a good copy to completely blank. =^..^=

    If you'd like a serious answer to your request:
    1) demonstrate that you've read the manual
    2) demonstrate that you made some attempt to fix it.
    3) if you're going to ask about jams include the jam code.
    4) if you're going to ask about an error code include the error code.


    blackcat: Master Of The Obvious =^..^=

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here