Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 4 of 4
  1. #1
    Senior Tech 250+ Posts Geo's Avatar
    Join Date
    Nov 2010
    Posts
    340
    Rep Power
    18

    MP C7500 with SC 542

    Hi Kids...

    I have been given the fun job of trying to resurrect a MP C7500. The box sat 4 years unused and when turned on gave a SC 542 error. I replaced all the thermistors (heat and press ) , cleared the code and I was able to run multiple test copies. This was done at the end of a Fri work week. The following Mon. customer called back with a the same code. Checked the outlet and all thermistors, lamps and thermofuses ..all seem to be OK.
    The copier will reset the code and will self check for several min before codeing out. I did check the temps during warm up and all modes were reading temp increases. I checked the SM for default temps but they are not provided and no birth recorders exist for this copier. Could the set temps be too low or high? Does anybody have the " default " setting ? Is a setting in service mode not properly set.?
    Any thoughts , ideas and solutions would be much appreciated.

    Thanks much
    P.S. Are we having fun yet...


  2. #2
    Retired 5,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    6,882
    Rep Power
    148

    Re: MP C7500 with SC 542

    SP 1105 in the service manual gives the default as 170 degree C.

    From Goose's guide:
    SC 542 Heating roller themistor error- Thermistor defective
    SC 542 Heating roller themistor error- Thermostat defective
    SC 542 Heating roller themistor error- Fusing lamps defective

    If you do not have and use Goose's Guide you should. It has been posted here multiple times. Find it and download.


  3. #3
    Trusted Tech 50+ Posts DRichard's Avatar
    Join Date
    May 2008
    Location
    Knoxville, TN
    Posts
    70
    Rep Power
    20

    Re: MP C7500 with SC 542

    Quote Originally Posted by slimslob View Post
    SP 1105 in the service manual gives the default as 170 degree C.

    From Goose's guide:
    SC 542 Heating roller themistor error- Thermistor defective
    SC 542 Heating roller themistor error- Thermostat defective
    SC 542 Heating roller themistor error- Fusing lamps defective

    If you do not have and use Goose's Guide you should. It has been posted here multiple times. Find it and download.
    Learn it. Live it. LOVE IT!


  4. #4
    The New Guy 1,000+ Posts ruben's Avatar
    Join Date
    Oct 2012
    Location
    Bristol, UK
    Posts
    1,185
    Rep Power
    42

    Re: MP C7500 with SC 542

    Some models can tell you what values were recorded by each thermistor at the time of the SC.

    SP1-113 Fusing SC Issue Time Info, even though it is marked as DFU should be accessible.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here