Results 1 to 6 of 6
  1. #1
    Field Supervisor 500+ Posts
    Join Date
    Jun 2012
    Location
    Turnhout
    Posts
    556
    Rep Power
    18

    mpc2800 no yellow on prints (rest ok), no error codes

    All colors fine, but no yellow is on the print out.
    Toner level indication is at 2 and there is no "add toner message" or ID error code error.
    In fact i have checked VSG and VSP and they were fine!
    Performed "music" and at the end of it it displays: "failed".
    Have cleaned and checked the pcu and developercase, seems fine to me...
    The machine was delivered a year ago, but the owner sometimes doesn't print for many months.
    Yet, this machine is always in stand by (at power save).
    Could that be a issue?
    Greetings


  2. #2
    Field Supervisor 500+ Posts Zeldaman's Avatar
    Join Date
    Mar 2011
    Location
    Stuttgart/Baden Wuerttemberg
    Posts
    742
    Rep Power
    29

    Re: mpc2800 no yellow on prints (rest ok), no error codes

    Hi there!
    Check the ITB-unit, maybe a broken wire, or the roller for yellow is out of position.
    Greetings...


  3. #3
    Technician FrohnB's Avatar
    Join Date
    Jul 2017
    Location
    Fremont, Nebraska
    Posts
    38
    Rep Power
    2

    Re: mpc2800 no yellow on prints (rest ok), no error codes

    I agree with zeldaman. Take the transfer belt off of the ITB unit, and look for a broken wire. The one time it happened to me was also missing yellow, and the wire for that had been rubbed and exposed.


  4. #4
    Senior Tech 100+ Posts
    Join Date
    Mar 2009
    Location
    Penang
    Posts
    126
    Rep Power
    20

    Re: mpc2800 no yellow on prints (rest ok), no error codes

    check the magnetic clutch of the yellow PCU also ..


  5. #5
    Field Supervisor 500+ Posts
    Join Date
    Jun 2012
    Location
    Turnhout
    Posts
    556
    Rep Power
    18

    Re: mpc2800 no yellow on prints (rest ok), no error codes

    After swapping the pcdu it worked fine, untill now...


  6. #6
    Field Supervisor 500+ Posts
    Join Date
    Jun 2012
    Location
    Turnhout
    Posts
    556
    Rep Power
    18

    Re: mpc2800 no yellow on prints (rest ok), no error codes

    Quote Originally Posted by Zeldaman View Post
    Hi there!
    Check the ITB-unit, maybe a broken wire, or the roller for yellow is out of position.
    Greetings...
    I have swapped the pcdu and it worked fine for a month. Now i have swapped the ITB unit and again, it is working fine.
    I have taken off the belt of the "bad" ITB unit and i can't see anything wrong. I think you mean with "wires" the white ground wires? They are all in good place and not broken nor twisted. Also the ground plates are in good position. The only thing i can think of is this:
    1. the downward movement of the ITB plate to the colour pcu's of the ITB clutch might not be "down" enough (gap).
    2. the grounding plates on the left rear side of the ITB unit (one of this two must be removed in procedure to remove the belt) might be at the wrong position. My service manual don't mention the wright position of these grounding plates. Are they underneath the metal removable bracket?
    Anyone?




Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here