Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    May 2019
    Location
    Geelong Victoria
    Posts
    2
    Rep Power
    0

    Lanier MP C2500 Printing random symbols when printing emails

    When printing some emails the copier just prints heaps of pages with random symbols.
    I have tried the latest universal driver but it still happens.
    On other brands of copiers this would happen if the driver or firmware aren't up to date.
    Would anyone have a link to download the latest firmware for this machine.
    Here are the current firmware versions on the machine.
    Printer 1.71 B7885601M System 1.71 B2385601X Engine 1.17:01 B2385530Q LCDC 1.27 B2381493B NIB 5.13 B2385605F.

    Cheers Simon

  2. #2
    Field Supervisor 500+ Posts
    Lanier MP C2500 Printing random symbols when printing emails


    Join Date
    Oct 2007
    Location
    San Diego, CA
    Posts
    763
    Rep Power
    32

    Re: Lanier MP C2500 Printing random symbols when printing emails

    Sounds like the universal driver is the problem.
    Try the PCL6 driver and make sure it is not installed on WSD port.

  3. #3
    Retired 5,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    9,302
    Rep Power
    203

    Re: Lanier MP C2500 Printing random symbols when printing emails

    The purpose of the universal driver is to allow different make and model printers to be pooled.

  4. #4
    Junior Member
    Join Date
    May 2019
    Location
    Geelong Victoria
    Posts
    2
    Rep Power
    0

    Re: Lanier MP C2500 Printing random symbols when printing emails

    Sorry I probably said the wrong thing when i said universal driver.
    I downloaded the driver from this website.
    The customer is using windows 10

    Aficio MP C2000/C2500/C3000 Downloads | Ricoh Global

    I used the one called

    PCL6 Driver for Universal Print Ver.4.22.0.0 Released Date: 14/05/2019New!

  5. #5
    Service Manager 2,500+ Posts
    Lanier MP C2500 Printing random symbols when printing emails

    sandmanmac's Avatar
    Join Date
    Feb 2009
    Location
    Toronto, ON
    Posts
    2,945
    Rep Power
    87

    Re: Lanier MP C2500 Printing random symbols when printing emails

    Quote Originally Posted by Simon View Post
    Sorry I probably said the wrong thing when i said universal driver.
    I downloaded the driver from this website.
    I used the one called PCL6 Driver for Universal Print

    Ver.4.22.0.0 Released Date: 14/05/2019New!


    Aficio MP C2000/C2500/C3000 Downloads | Ricoh Global
    You didn't say the wrong thing.
    It appears that there is not a full driver package for that really, really old model.
    I'd suggest installing either the PCL 5c or PCL6 driver for a newer model like the MP C3001 or C3002 to try and resolve the issue. It will work perfectly fine, and anything is better than the universal PCL driver.
    As for firmware.....I'm sure there have been no updates for many years - We're talking about a 2006 model after-all. At this point , you'll have to live with a few 'glitches'

  6. #6
    Retired 5,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    9,302
    Rep Power
    203

    Re: Lanier MP C2500 Printing random symbols when printing emails

    Quote Originally Posted by Simon View Post
    Sorry I probably said the wrong thing when i said universal driver.
    I downloaded the driver from this website.
    The customer is using windows 10

    Aficio MP C2000/C2500/C3000 Downloads | Ricoh Global

    I used the one called

    PCL6 Driver for Universal Print Ver.4.22.0.0 Released Date: 14/05/2019New!
    Ricoh has gotten lazy when it comes to populating the driver page for models that they want you to trade in and scrap. From the link you posted, scroll down and under Windows select either Windows 8.1 or Windows 7for which ever Windows 10 you have, 64 bit or 32 bit.

  7. #7
    Service Manager 2,500+ Posts
    Lanier MP C2500 Printing random symbols when printing emails

    sandmanmac's Avatar
    Join Date
    Feb 2009
    Location
    Toronto, ON
    Posts
    2,945
    Rep Power
    87

    Re: Lanier MP C2500 Printing random symbols when printing emails

    Quote Originally Posted by slimslob View Post
    Ricoh has gotten lazy when it comes to populating the driver page for models that they want you to trade in and scrap. From the link you posted, scroll down and under Windows select either Windows 8.1 or Windows 7for which ever Windows 10 you have, 64 bit or 32 bit.
    Good point ,Tim. That's an even better option. I didn't think to suggest that.....oops

  8. #8
    Field Supervisor 500+ Posts
    Lanier MP C2500 Printing random symbols when printing emails

    guitar9199's Avatar
    Join Date
    Sep 2016
    Location
    Eveleth, MN
    Posts
    846
    Rep Power
    22

    Re: Lanier MP C2500 Printing random symbols when printing emails

    When a driver prints "Gibberish" like that, it's usually because the fonts aren't supported. Press user tools/counter>printer features and see if the machine has Postscript, or as someone else suggested, use PCL5 drivers.....

    You're dealing with a machine series that was released in 2006, so 13 years is a long time.

  9. #9
    Technician 8T2's Avatar
    Join Date
    Aug 2015
    Location
    Secunda, Mpumalanga
    Posts
    37
    Rep Power
    8

    Re: Lanier MP C2500 Printing random symbols when printing emails

    You could also ask user to print mail to pdf and then print pdf to printer. Extra step but at least it's not wasting paper.

    Sent from my ALE-L02 using Tapatalk

  10. #10
    Master Of The Obvious 10,000+ Posts
    Lanier MP C2500 Printing random symbols when printing emails

    blackcat4866's Avatar
    Join Date
    Jul 2007
    Location
    Lapeer, Michigan
    Posts
    17,249
    Rep Power
    289

    Re: Lanier MP C2500 Printing random symbols when printing emails

    Quote Originally Posted by guitar9199 View Post
    When a driver prints "Gibberish" like that, it's usually because the fonts aren't supported. Press user tools/counter>printer features and see if the machine has Postscript, or as someone else suggested, use PCL5 drivers.....

    You're dealing with a machine series that was released in 2006, so 13 years is a long time.
    I think this is getting closer to the mark.

    The generic term "PostScript error" refers to a mismatch of print driver language to printer emulation. For example you may be sending PCL data to a PS designated printer, or vice-versa. The typical PostScript error is a single line of characters, including many smilies, symbols and foreign characters, often hundreds or thousands of pages. Essentially the printer cannot decode the print language so it prints the data exactly as it arrives at the printer. =^..^=
    If you'd like a serious answer to your request:
    1) demonstrate that you've read the manual
    2) demonstrate that you made some attempt to fix it.
    3) if you're going to ask about jams include the jam code.
    4) if you're going to ask about an error code include the error code.
    5) You are the person onsite. Only you can make observations.

    blackcat: Master Of The Obvious =^..^=

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here