Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 32
  1. #11
    Technician
    Join Date
    Dec 2009
    Posts
    27
    Rep Power
    19
    I've had this on an MPC3300 (Athena C2). Display was blank and printer light red indicating an error. Found showing SC202 using WIM.
    The polygon motor was faulty and had taken out the BICU board. I replaced them both as a pair to cure. Hope this helps.

  2. #12
    Junior Member pearl85's Avatar
    Join Date
    Apr 2011
    Location
    CHENNAI
    Posts
    5
    Rep Power
    0
    please check the plygonmirror motor and BICU Board

  3. #13
    Service Manager 250+ Posts Masterchief's Avatar
    Join Date
    Apr 2011
    Posts
    290
    Rep Power
    22
    How come you found it hard to remove the ITB? have you tried removing all the PCU's fusing unit etc and tried powering on. Im sure with the pcu's out it will be alot easier to remove the ITB

  4. #14
    Senior Tech 250+ Posts sharpmind's Avatar
    Join Date
    Sep 2009
    Posts
    452
    Rep Power
    23

    It's a bloody machine.....

    Guys, until now we're not able to locate the problem of this machine (MPC 2500) having no display but the buttons in the operation panel are working.Already replaced all the boards and had disconnected major wirings and connectors yet the solutions to the problem remain mystery.

    Any more ideas to share with????

  5. #15
    Junior Member pearl85's Avatar
    Join Date
    Apr 2011
    Location
    CHENNAI
    Posts
    5
    Rep Power
    0
    please change the polygonmirror motor and BICU board at a same time..

  6. #16
    Technician rpr383's Avatar
    Join Date
    Apr 2010
    Location
    Bay City,Mi.
    Posts
    14
    Rep Power
    18
    Quote Originally Posted by pearl85 View Post
    please change the polygonmirror motor and BICU board at a same time..
    I agree with pearl85 I have had this exact same thing happen to me! They just came out with a T/P.

  7. #17
    FORMER Techie 1,000+ Posts tcs04's Avatar
    Join Date
    Apr 2009
    Posts
    1,191
    Rep Power
    32
    You may have a PSU problem. Check the 5v and 24v supply to the op panel. This could also be causing a secondary MUSIC error (SC202 or similar) later, sort of as described by Ricohslave, but due to lack of trigger to the lasers. I have had Power Supplies cause similar issues several times. I would simply turn the panel over and check the inputs before ordering the (expensive) BCU and Polygon motor.

  8. #18
    Senior Tech 250+ Posts sharpmind's Avatar
    Join Date
    Sep 2009
    Posts
    452
    Rep Power
    23
    Thanks a lot guys! After replacing the BICU and the polygon mirror motor at the same time the display worked fine.At last the pain in our ass had gone!Cheers!

  9. #19
    Hair Straightener Tech 500+ Posts rsyarcia's Avatar
    Join Date
    Feb 2008
    Location
    Nueva Vizcaya
    Posts
    708
    Rep Power
    34
    good!!
    Nobody is perfect..

  10. #20
    Senior Tech 100+ Posts
    Mpc 2500 no display

    nobody-here's Avatar
    Join Date
    Mar 2008
    Posts
    194
    Rep Power
    23

    Re: Mpc 2500 no display

    Same problem,
    mpc2500 sc202 and black screen.

    I changed Bicu and Polygon motor.... but without success. Maybe because I changed them not simultaneously but first I tried Polygon Motor then (after a power on) BICU.
    My question is... Does I damaged those new parts?

    What else can I try.

    Thanks for your help!

    Vincenzo
    29 rouge unpair manque.... cous cous....

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here