Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 32
  1. #21
    Senior Tech 250+ Posts Polo-022's Avatar
    Join Date
    Sep 2007
    Posts
    320
    Rep Power
    26

    Re: Mpc 2500 no display

    Hello Vincenzo,
    i think you have started from the oppossite side...
    Check your PSU first for 24V if available...

  2. #22
    Junior Member balazs.fried's Avatar
    Join Date
    Aug 2010
    Location
    Budapest
    Posts
    6
    Rep Power
    0

    Re: Mpc 2500 no display

    Quote Originally Posted by pearl85 View Post
    please change the polygonmirror motor and BICU board at a same time..
    Hi pearl85, Thanks for the advice. We had 2 machines with the same problem. We have changed the BICU and polygon at the same time and it worked, bot machines are fine now.THANKSBalazs

  3. #23
    Junior Member
    Join Date
    Oct 2015
    Posts
    1
    Rep Power
    0

    Re: Mpc 2500 no display

    Had the same problem, u got to replace polygon motor and repair/replace bicu in the same time.

    in my case resistor "R157" on the BICU was dead. Just replaced the resisor and machine works good.

  4. #24
    Trusted Tech 50+ Posts jam-o-matic's Avatar
    Join Date
    Oct 2012
    Posts
    72
    Rep Power
    13

    Re: Mpc 2500 no display

    glad it's fixed - just a tip from running into this; you can web into the machine using the WIM (IP address thru browser) and it will show the SC code. Usually related to polygon mirror motor (SC202)

  5. #25
    Service Manager 2,500+ Posts
    Mpc 2500 no display

    sandmanmac's Avatar
    Join Date
    Feb 2009
    Location
    Toronto
    Posts
    2,820
    Rep Power
    80

    Re: Mpc 2500 no display

    Quote Originally Posted by Ricohfreaks View Post
    Had the same problem, u got to replace polygon motor and repair/replace bicu in the same time.

    in my case resistor "R157" on the BICU was dead. Just replaced the resisor and machine works good.
    Quote Originally Posted by jam-o-matic View Post
    glad it's fixed - just a tip from running into this; you can web into the machine using the WIM (IP address thru browser) and it will show the SC code. Usually related to polygon mirror motor (SC202)
    This is all good info, but it's been suggested, discussed, and resolved multiple times - and over 4 years ago in the first 2 pages of this thread (and many, many others!)

  6. #26
    Senior Tech 100+ Posts
    Join Date
    Oct 2011
    Posts
    124
    Rep Power
    16

    Re: Mpc 2500 no display

    Quote Originally Posted by Ricohslave View Post
    I've had this on an MPC3300 (Athena C2). Display was blank and printer light red indicating an error. Found showing SC202 using WIM.
    The polygon motor was faulty and had taken out the BICU board. I replaced them both as a pair to cure. Hope this helps.
    Do it today and really helped, thank you !!!

  7. #27
    Junior Member
    Join Date
    Feb 2016
    Location
    Hunzenschwil
    Posts
    1
    Rep Power
    0

    Thumbs up Re: Mpc 2500 no display

    Quote Originally Posted by Ricohfreaks View Post
    Had the same problem, u got to replace polygon motor and repair/replace bicu in the same time.

    in my case resistor "R157" on the BICU was dead. Just replaced the resisor and machine works good.


    Brooooooo YOU ARE MY HERO TODAY!!!!
    I checked R157 and its a 0 (Zero) Ohm resistor and it is open.
    I will replace it with another on or maybe with an short.

    After replace the 0 Ohm R157 the 24 volts are back on the polygon laser drive
    but it smoke the R157 again... and this time the polygon laser drive is melted down.

    I buy a new polygon laser drive and do the R157 again.
    Last edited by rymannphilippe; 2 Weeks Ago at 07:45 PM.

  8. #28
    Senior Tech 250+ Posts tufbnme's Avatar
    Join Date
    Feb 2008
    Location
    Mexifornia
    Posts
    442
    Rep Power
    27

    Re: Mpc 2500 no display

    [Symptom]
    The power cannot be turned ON (The main power lamp is lit.). SC202, SC203, or SC204 is displayed. The problem is not fixed by replacing the polygon motor.
    Note:
    When turning the main power ON, the LCD display on the operation panel and the power lamp does not turn on. (The main power lamp is only lit.) In addition, "Cover Open" does not appear and the machine does not start initializing.
    Or, SC202, SC203, or SC204 error is displayed.
    The SC errors are not fixed by replacing the polygon motor.



    [Cause]
    The fuse on the PSU blows.
    Note:
    When the polygon motor is damaged (burned), the 24V fuse blows to protect the PSU from the excess-current.
    The initialization does not start because 24V is not supplied to the MB.
    [Solution]
    Replace the fuse on the PSU. (6.3A)

  9. #29
    Service Manager 1,000+ Posts
    Join Date
    Jan 2009
    Location
    nyc
    Posts
    1,111
    Rep Power
    38

    Re: Mpc 2500 no display

    Quote Originally Posted by rymannphilippe View Post
    Brooooooo YOU ARE MY HERO TODAY!!!!
    I checked R157 and its a 0 (Zero) Ohm resistor and it is open.
    I will replace it with another on or maybe with an short.

    After replace the 0 Ohm R157 the 24 volts are back on the polygon laser drive
    but it smoke the R157 again... and this time the polygon laser drive is melted down.

    I buy a new polygon laser drive and do the R157 again.

    if you look at the laser unit there will be bad solder joints/gaps And i cant say i would try to resolder them...but just a thought..

  10. #30
    Ricoh Fanboy 1,000+ Posts Oze's Avatar
    Join Date
    Jul 2008
    Location
    Toowoomba
    Posts
    1,263
    Rep Power
    38

    Re: Mpc 2500 no display

    Sigh....7 yr old thread

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here