Results 1 to 10 of 10
  1. #1
    Trusted Tech 50+ Posts
    Join Date
    Aug 2009
    Posts
    86
    Post Thanks / Like
    Rep Power
    0

    aficio mp7500 finisher problem

    Dear sir
    I have same problem on 2 on my aficio mp7500 machines finisher , that papers do not output in the right way i don't know exactly how to describe it so I took pictures ,pleas find attached pics.

    Attached Images Attached Images

  2. #2
    Trusted Tech 50+ Posts semi's Avatar
    Join Date
    Sep 2008
    Location
    UK
    Posts
    63
    Post Thanks / Like
    Rep Power
    13

    Re: aficio mp7500 finisher problem

    Where's the sponge exit rollers???


  3. #3
    Carbon Chimp 2,500+ Posts TonerMunkeh's Avatar
    Join Date
    Apr 2008
    Posts
    2,569
    Post Thanks / Like
    Rep Power
    51

    Re: aficio mp7500 finisher problem

    I was just thinking that. Jogger assembly but no gathering rollers. As Adam Savage would say - "there's your problem".

    Grrr. Arrrg. Brains. Arrrg.

  4. #4
    It's GREEN Again! :-) 100+ Posts
    Join Date
    May 2011
    Location
    A Small City in MI
    Posts
    162
    Post Thanks / Like
    Rep Power
    9

    Re: aficio mp7500 finisher problem

    You are missing at least some, if not all, of the parts circled in the attached image. Part #29 in the diagram are the foam rollers that the others are talking about...

    (CLICK ME!)
    missing_parts.jpg


  5. #5
    Trusted Tech 50+ Posts
    Join Date
    Aug 2009
    Posts
    86
    Post Thanks / Like
    Rep Power
    0

    Re: aficio mp7500 finisher problem

    Dear allThank you for your replay , the sponge rollers are there , please find attached pic , but my problem is that the output papers comes on top of these rollers not under them


    Attached Images Attached Images

  6. #6
    Senior Tech 100+ Posts redneckstylin's Avatar
    Join Date
    Sep 2011
    Location
    prince george
    Posts
    136
    Post Thanks / Like
    Rep Power
    8

    Re: aficio mp7500 finisher problem

    they look a little on the worn side of things from my veiw


  7. #7
    Junior Member
    Join Date
    Jan 2012
    Location
    Fort Worth,Tx
    Posts
    2
    Post Thanks / Like
    Rep Power
    0

    Re: aficio mp7500 finisher problem

    Yeah u need to change those sponge rlrs their worn


  8. #8
    Senior Tech 100+ Posts neergish's Avatar
    Join Date
    Feb 2008
    Location
    A little bit to the left of the centre of the known universe.
    Posts
    161
    Post Thanks / Like
    Rep Power
    15

    Re: aficio mp7500 finisher problem

    Agreed,looks like the sponge rollers to me as well. I always carry a couple in my in my service kit these days.

    "See if you can rent a spring hook and a phillips screwdriver it will make your life that much easier..."

  9. #9
    Senior Tech 100+ Posts
    Join Date
    Aug 2008
    Location
    ACT 2620
    Posts
    113
    Post Thanks / Like
    Rep Power
    14

    Re: aficio mp7500 finisher problem

    Quote Originally Posted by Madtaz View Post
    Yeah u need to change those sponge rlrs their worn
    x2 you should also be hearing a clicking noise when these loose there shape.


  10. #10
    Trusted Tech 50+ Posts
    Join Date
    Aug 2009
    Posts
    86
    Post Thanks / Like
    Rep Power
    0

    Re: aficio mp7500 finisher problem

    I replace the sponge rollers and every thing is OK
    THANK YOU ALL


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here