Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    Trusted Tech 50+ Posts
    Join Date
    Mar 2011
    Posts
    58
    Rep Power
    14

    Aficio 1075 dirty prints - iamge ghosting

    The print as well as copies are dirty. It appears like ghost prints. I replaced the drum, cleaning blade, new developer no luck. Exact same issue.
    What am I missing? any help is much appreciated.


  2. #2
    Field Supervisor 500+ Posts
    Join Date
    Apr 2010
    Location
    the west
    Posts
    541
    Rep Power
    23

    Re: Aficio 1075 dirty prints - iamge ghosting

    Check the Hot Roller. It can cause this type of image problem


  3. #3
    Trusted Tech 50+ Posts
    Join Date
    Mar 2011
    Posts
    58
    Rep Power
    14

    Re: Aficio 1075 dirty prints - iamge ghosting

    Thank you. Will check it out today and post and update.


  4. #4
    Trusted Tech 50+ Posts
    Join Date
    Mar 2011
    Posts
    58
    Rep Power
    14

    Thumbs up Re: Aficio 1075 dirty prints - iamge ghosting

    The cleaning web seems to be not turning that caused the ghosting images. Thanks a lot jonhiker for pointing me in the correct direction. I really appreciate your help.


  5. #5
    Senior Tech 100+ Posts
    Aficio 1075 dirty prints - iamge ghosting


    Join Date
    Dec 2010
    Location
    Texas
    Posts
    236
    Rep Power
    17

    Re: Aficio 1075 dirty prints - iamge ghosting

    It's fairly common for the web motor to go out on the 1060s due to their age. Usually you get a call for a noise that you can't duplicate caused by the web bunching up & rubbing the hot Roller. You can swap it out with the main charge cleaner motor - you just have to change Sp2804 to OFF or you'll get an Sc305 & splice the longer harness onto it. I used to carry the motor in my car stock.

    The newer 6002s have made the situation even worse! Now you get an Sc540 and it isn't an aging issue. We did a school district install last summer. When school opened for the year, we were averaging about 6 or 7 calls a week for Sc540s. The tech who handles the account keeps about 5 motors in his car stock.


  6. #6
    Trusted Tech 50+ Posts
    Join Date
    Mar 2011
    Posts
    58
    Rep Power
    14

    Re: Aficio 1075 dirty prints - iamge ghosting

    Quote Originally Posted by techsass View Post
    It's fairly common for the web motor to go out on the 1060s due to their age. Usually you get a call for a noise that you can't duplicate caused by the web bunching up & rubbing the hot Roller. You can swap it out with the main charge cleaner motor - you just have to change Sp2804 to OFF or you'll get an Sc305 & splice the longer harness onto it. I used to carry the motor in my car stock.

    The newer 6002s have made the situation even worse! Now you get an Sc540 and it isn't an aging issue. We did a school district install last summer. When school opened for the year, we were averaging about 6 or 7 calls a week for Sc540s. The tech who handles the account keeps about 5 motors in his car stock.
    I hear you. I really didn't think that the hot roller, where the toner never gets in, can cause the ghosting... Learning Every day. Thanks for the additional info on the newer ones.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here