PDA

View Full Version : BizHub C200 locked up


Custom Search


copyman
12-28-2015, 10:39 PM
Machine was moved recently but has been working good for about a month at new location.

Screen is locked up with just the diagram of the copier. No messages or anything else on screen. Machine cycles, fuser heats up, fans run, etc, etc

Tried unplugging, reset memory, etc. Did not work.

I know the C200 is the ugly stepsister of the C253 series and have never worked on one. They look very similar to C253, except the old style op panel, controller, few other things. I know the C253 can have problems with NVRAM locking up screen. Not sure if this model has the same problem?

Was going to try firmware?

Thanks for the help

EarthKmTech
12-28-2015, 10:50 PM
this model is a piece of shit and that is my professional opinion. I had just 3 in my area and I am very thankful they are now all gone.

you can try the firmware but if it gets to the point of needing to order an MFP board which it did for me, think very long and hard before doing that - I was able to convince the boss to dump it and replace it with a used C253 when this happened to me.

copier addict
12-29-2015, 12:23 AM
I have never seen a C200, but if it is similar to a C253 failed memory modules can cause the machine to lock up.

Custom Search