PDA

View Full Version : BizHub C300 Scanning config help humbly requested


Custom Search


Snurtle
04-01-2013, 01:38 AM
Hi Everyone,

I have a Konica Minolta C300 that scanned fine to the Macs on our network until I upgraded to 10.7. I've done my research on this issue—aware that Lion eliminated support for SMB, and like many, I waited for a solution. I recently found this forum, read the threads on SMBUp, and have it downloaded and installed, and it seems to be running fine.

I've really done my best to figure out how to make all this work, but I'm still doing something wrong because I can't get it to scan successfully. I think I'm close, but not quite there... probably something really obvious (doh!). Would someone mind pointing me in the right direction for figuring out what I'm doing wrong? I have to scan THOUSANDS of docs over the next several months, and really need this to work. (Printing is no problem on the network, btw)

Here are screenshots of all my settings: sharing, printer screen, and PageScope

Thank you in advance for any help—I'm VERY grateful!

blackcat4866
04-01-2013, 02:33 AM
In screen shot #3: Read Only(RO)?

I would think you'd want Read & Write. =^..^=

Snurtle
04-01-2013, 02:49 AM
Blackcat wrote:
"In screen shot #3: Read Only(RO)?

I would think you'd want Read & Write. =^..^="



DOH!!! Thanks, Blackcat. I'll fix that in SMBUp right away....

Does everything else look ok?

blackcat4866
04-01-2013, 03:03 AM
That's the only thing that caught my eye.

Did you use a blank password to the MAC, or does it just display blank once submitted? If entered as blank, I would create a password and use it.
Good Luck. =^..^=

Mr Spock
04-01-2013, 06:35 AM
That's the only thing that caught my eye.

Did you use a blank password to the MAC, or does it just display blank once submitted? If entered as blank, I would create a password and use it.
Good Luck. =^..^=

This model does not show password after entered and saved.

On the screen shot of the mac (with the windows smb check box) remove christopher and uncheck box. Then recheck add christopher and password (have not seen it work without one).
Use this password on the address book setup.
Also I think you only need the "scans" in the folder address. I do not think it needs the whole path in there.

Snurtle
04-01-2013, 07:37 AM
This model does not show password after entered and saved.

On the screen shot of the mac (with the windows smb check box) remove christopher and uncheck box. Then recheck add christopher and password (have not seen it work without one).
Use this password on the address book setup.
Also I think you only need the "scans" in the folder address. I do not think it needs the whole path in there.

Thank you, Mr. Spock—I am very grateful for the help. Everything you suggest is MOST logical! ; )

So, I went back into my system prefs and did as you suggested: unchecked the box, re-checked it and entered the password. Then went back into PageScope and made the other changes you suggested. Here's my new screenshot from PageScope, but it's still returning a "Server Connect Error" when I go to the job detail on the Bizhub control pad.

eduo
04-01-2013, 01:20 PM
Hello.

You can do three things:

1.-The "remote path" you're defining (destination) is specifying a path that doesn't match the folder you're sharing. When you're sharing "/Users/cjdery/Public/Scans" then for the remote machine this whole path is "/". If you were sharing "/Users/cjdery/Public" then the destination path should be "/Scans".

2.-User permissions are sort of weird for Samba, in the sense that you have to create local users for Samba but they must be shared with the local users. You are using a local user ("cjdery") but Samba doesn't know about it. This means that either it's falling back to a "guest" account or failing to connect. In case it's falling back to guest access you can change the "force user" line in the "Advanced Shared Disk Settings" to be "cjdery" and the "guest user" in the "Advanced Server Configuration" to "cjdery". The former forces all connections to your shared disk to be mapped to your user and the latter forces all "guests" to be mapped to your user. Only do this if you don't have any other accesses or shared folders, since essentially it's opening up your shared folders to the network (if it makes them work you can disable one or the other to find which one did it).

3.-If the above doesn't help you (although #1 should be mandatory) you can try creating a share-only user and use that to connect:

a.-In the Accounts system preferences sections create a new user as "sharing only", take note of the short username and password.
b.-Open the terminal and create the special user for Samba:

sudo /opt/local/bin/smbpasswd -a username
sudo /opt/local/bin/smbpasswd -e username

(in both cases you should be asked for the password, use the same username and password you used originally)

c.-Make sure the shared folder you're sharing has permissions to share with the newly-created user.

eduo
04-01-2013, 01:39 PM
Hi.

I decided to try and make the instructions clearer from scratch.

0.-Remove the current config everywhere
0.1.-Delete the shared folder from SMBUp (select and click the delete key)
0.2.-Remove the configuration from the scanner
0.3.-Remove any user you might have created especifically for this in SMBUp

1.-Create a sharing-only user
1.1.-Open System Preferences
1.2.-Open Accounts
1.3.-Unlock que padlock, if it's locked
1.4.-Click the "+" button to add a new user and select "Sharing Only" from Pop-up
1.5.-Set the Full Name, Account Name (username) and password. Make note of the username and password


2.-Set the permissions of your shared folder.
2.1.-Open System Preferences
2.2.-Open Sharing and select File Sharing
2.3.-Ensure File Sharing is "Off" (unchecked) or, at least, Windows File Sharing (SMB) in Options.
2.4.-Under File Sharing, in the Shared Folders section, click the "+" button and select the disk or folder you want to share
2.5.-For the selected shared folder make sure to set the Read & Write permissions you wish
2.6.-Add the user created in step 1 by pushing on the "+" button and selecting
2.7.-Set the permissions for the user from step 1 to read & write
2.8.-Ensure File Sharing is "Off" (unchecked) or, at least, Windows File Sharing (SMB) in Options (it really needs to be off!)


3.-Add the user to Samba manually.
3.1.-Open /Applications/Utilities/terminal.app
3.2.-Add and enable the user (each command is a single line, with "enter" at the end, "username" is the short username for the user created in step #1)
sudo /opt/local/bin/smbpasswd -a username
sudo /opt/local/bin/smbpasswd -e username
(the first command first asks for the admin password, then for the username's password, use the same ones you created in step 2)
(this will be fixed in a future version of SMBUp so the terminal can be avoided)


4.-Add the share to SMBUp
4.1.-Open SMBUp
4.1.-Drag and drop the folder you want to share to SMBUp's main folder list (or use "add new shared drive" button)
4.2.-Uncheck "Allow Guest" to only allow authenticated users. Uncheck "Read Only" as you'll want to write here.
4.3.-With the shared folder selected in SMBup click on Manage Users
4.4.-The user created in step #1 should be already listed in the lower pane. Select, add and close.
4.5.-IMPORTANT: Click the padlock to force a file save. When unlocked click "Save All"
4.6.-IMPORTANT: Stop the Samba Service and start it again, for the changes to take effect.


5.-Samba should be up and running and the disk should be viewable on the network.

As for the scanner:

6.-Set the Scanner's settings
6.1.-Remember that "/" in the scanner is already the full path shared in SMBUp. If you want to share "/Users/cjdery/Public/Scans" then "/" in the scanner is already this. If you share ""/Users/cjdery/Public" then the scanner's destination should be "/Scans".
6.2.-Remember that the scanner's config must have the user and password you specified in step 3. Exactly (lower/uppercase is important).
6.3.-By default Samba logs everything in /var/log/samba.log.%m where %m is the machine name connecting to the server. You might see errors there as well that might provide more info.

One tip: Using the same words in different places may lead to hard-to-troubleshoot problems. Your name in your machine is "christopher", your machine name is "christopher" and you're using user id "christopher". I suspect your user ID is really "cjdery" but it's hard to be clear because "christopher" is being used everywhere and you may just have created another account whose short username is "christopher". You're also sharing a folder named "Scans" with a shared name of "scans", but both things are not the same and this is also leading to confusion. If you were sharing "/Users/cjdery/Public" then your destination path would be "/Scans/Scans" because the first in the path is the share name.

Custom Search