PDA

View Full Version : Lexmark power problem


Custom Search


Caldo
03-28-2008, 01:19 AM
Hi Guys,

Plis anyone can help me out on this situation?

I have come across this with four lexmark printers and i'am still trying to figure out what the cause of this.

The problem is that the printers don't recieve power and the LCD screen does not light up, finding this problem i tried to change the AC power adaptors workable ones, still the same. Thought it was the power board, but then something else came up that made me to re-think, the catridge holder which holds the cartridge has a red light under it sort of scan light.

This is of sure that the power comes in the printer, but what makes it that the LCD screen does not power up, for sure it can't happen to four printer at one time?

Any help would be very much appreciated, as it is making me more confused.

Regards

Caldo:confused:

blackcat4866
03-28-2008, 03:18 AM
What models? If you're talking about S1255 or S2455 its very common to have the display go out. Just replace the display.

=^..^=

Caldo
03-28-2008, 04:23 AM
The models are X8350, these are multi-function ones that do everything.

blackcat4866
03-29-2008, 03:55 AM
I haven't any experience with these.

=^..^=

Caldo
03-31-2008, 01:32 AM
This ones recieve power, but after switching it on the LCD display panel lits up for 2-3 seconds before turning off again, at which nothing appears at the panel screen either only the blue lights of the display panel button.

I have tried changing the flat cable that connects the panel screen and the controller board, but it's the same.

Can anyone plis give me an idea on what to do next?

Custom Search