PDA

View Full Version : Lexmark power problem


Custom Search


Caldo
04-02-2008, 01:13 AM
Hi Guys,

Has anyone come across this type of problem?

Especially with the Lexmark X5400 & X8300 series, the problem i have come to face is that of all the printers i have called to check out, all have the same problem, which is power failure in the LCD display panel.
The power does come in but not in the LCD display screen, nothing shows when the printer is switched on even the lights on the control panel don;t come on.

I have tried changing the display panel but still it has the problem and i'am begining to be more confused.With no service manual also for this type i seem to go nowhere.

Is this caused by power failure with the local power authority or is there some other way to solve this common problem?

Somebody plis help!!!

Caldo

JustManuals
04-02-2008, 02:23 AM
Why don't you have an electrician come in and check your outlets?
Or you could try another outlet on a different circuit.

HtH
Paul@justmanuals.com

Caldo
04-03-2008, 03:01 AM
I tried all the outlets, still the same. I strongly suggest that it is the controller board in the printer, but i haven't got any proff yet.... iam still working on it if i manage to identify the problem i will let you know.

Caldo

Wild Bill
04-21-2008, 03:09 AM
Possible Power Supply problem. Replace the Low Voltage power supply board.- The display is not getting power.

Did you say you are getting power to the lcd display? You also replaced the display board?

I also would check "Memory" and System Board.

Caldo
04-22-2008, 01:23 AM
I think the memory and system board is okay, the display LCD is not getting power but if you look inside the printer there is a red light under the cartridge holder, which means power is actually coming in but not through to the LCD panel display. I can't think of any other possible solution but i will try your suggestion on replacing the Low Voltage Power Supply Board....... will let you know what happens!

Custom Search