PDA

View Full Version : Riso RP Drum problems


Custom Search


lberlen
05-01-2008, 03:19 AM
I am having problems inserting a different color drum into a RP3700 . For some strange reason the drum will not engage into the machine.

The only thing I noticed is the Flange drive gear is not at the correct angle and will not fit into the connector inside the Machine.

The Flange alignment markings are slightly off.

Can anyone help me with re-alignment steps -

techathens
05-01-2008, 04:56 PM
I am having problems inserting a different color drum into a RP3700 . For some strange reason the drum will not engage into the machine.

The only thing I noticed is the Flange drive gear is not at the correct angle and will not fit into the connector inside the Machine.

The Flange alignment markings are slightly off.

Can anyone help me with re-alignment steps -


Is it just the color cylinders and does the black cylinder install ok?

LHS

lberlen
05-01-2008, 10:47 PM
Its just the color drum the black is fits fine

cobiray
05-02-2008, 02:54 AM
Sounds like the drum timing is off. When this happens the plastic gear on the drum is sometimes worn or damaged. If you re timed the drum and it goes out of whack again you might want to replace the gear.

techathens
05-02-2008, 03:36 PM
With cobiray's suggestion in mind: check the timing marks on the main drive and second paper feed with the black cylinder in the unit and the timing in Home Position.

If all the timing marks line up then I would suggest to realign the Cylinders with themselves starting with the Black Cylinder. Do you have the instructions and the jig? The jig is called the Adjuster 7 [RISO part #: 015-26128-008] and goes through both front [Flange F] and rear [Flange R] - there are timing marks on the Flange Drive Gear and Flange R that have to be aligned. What happens usually the screws on a black cylinder (from use) will loosen and allow migration/movement. Check tightness on all the screws (Allen/Hex and Phillips) front and back of cylinder.

Good Luck!

kiwitechnician
12-16-2008, 07:38 PM
Have you tried to setup the B position on this drum ? If you put there too large number you may get T22 message. If is adjustment not usefull you have to do the mechanical timming on the main drive.

Custom Search