PDA

View Full Version : Drivers and Authentication


Custom Search


blackcat4866
02-07-2015, 05:10 PM
I discovered an interesting limitation on the drivers yesterday.

We were arranging a loaner for a bizhub 554e, and naturally, we didn't have the exact replacement on hand. But we do have a bizhub C554e. The enduser experience is almost indistinguishable, so its a good second choice, excepting for one thing. They use Account Tracking-Password Only.

In out testing in the office we saw that the monochrome driver prints fine to the color device, and to noone's surprise the images are always monochrome. That's fine, since they're not paying for color clicks anyway. During the installation though, we discovered that the authentication fouls it up. My guess is that in the monochrome driver Account Tracking is missing color selection data that the color box needs. For example, "Can I copy color? No data!" We were hoping to just drop the loaner in, without affecting IT, but that didn't work out.

Since all functions are authenticating with Account Track, it was easy to limit usage to Black Only. To confirm, I tested directly from my laptop with the same result. Monochrome and color drivers both work when Account Track is Off. Only the color driver works when Account Track is On.

IT is loading new drivers Monday. I just thought that was interesting. =^..^=

wseyller
02-07-2015, 06:26 PM
When using account track you have to use the driver that is made for its model. If using the driver for the 554e on a C554e then the encryption key is different. So when the copier decrypts the password it is incorrect. To use the wrong driver would require changing the factory encryption passphrase on the device and then adding this phrase into the driver.

Even the C454e encryption phrase is different from a C554e even though the same driver the auto obtain settings determine which model is in use and uses the correct phrase.

In the case of Mac you have to even make sure you pick the correct model within the series or account track password decryption will be incorrect.

blackcat4866
02-07-2015, 09:42 PM
When using account track you have to use the driver that is made for its model. If using the driver for the 554e on a C554e then the encryption key is different. So when the copier decrypts the password it is incorrect. To use the wrong driver would require changing the factory encryption passphrase on the device and then adding this phrase into the driver.

Even the C454e encryption phrase is different from a C554e even though the same driver the auto obtain settings determine which model is in use and uses the correct phrase.

In the case of Mac you have to even make sure you pick the correct model within the series or account track password decryption will be incorrect.

That's good to know. Thanks. =^..^=

Custom Search