Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Trusted Tech 50+ Posts
    Join Date
    Jan 2018
    Posts
    59
    Rep Power
    4

    C3520i print issue

    Tried switching fixing film unit, changed belt, drums, cleaned laser. Same result.

    Any help is highly appreciated.

    Br.

    Sent from my Moto E (4) Plus using Tapatalk

  2. #2
    Service Manager 10,000+ Posts
    C3520i print issue

    teckat's Avatar
    Join Date
    Jan 2010
    Location
    VA
    Posts
    15,905
    Rep Power
    230

    Re: C3520i print issue

    Quote Originally Posted by darkocg88 View Post
    Tried switching fixing film unit, changed belt, drums, cleaned laser. Same result.

    Any help is highly appreciated.

    Br.

    Sent from my Moto E (4) Plus using Tapatalk



    does smear issue travel on continuous printing ?

    paper feed or cross-feed direction
    **Knowledge is time consuming, exhausting and costly for a trained Tech.**

  3. #3
    Trusted Tech 50+ Posts
    Join Date
    Jan 2018
    Posts
    59
    Rep Power
    4

    Re: C3520i print issue

    Quote Originally Posted by teckat View Post



    does smear issue travel on continuous printing ?

    paper feed or cross-feed direction
    Yeah it travels.

    Sent from my Moto E (4) Plus using Tapatalk

  4. #4
    Trusted Tech 50+ Posts nicknt82's Avatar
    Join Date
    Nov 2011
    Location
    hochiminh
    Posts
    57
    Rep Power
    16

    Re: C3520i print issue

    Quote Originally Posted by darkocg88 View Post
    Tried switching fixing film unit, changed belt, drums, cleaned laser. Same result.

    Any help is highly appreciated.

    Br.

    Sent from my Moto E (4) Plus using Tapatalk


    Do you check Cleaning Belt? check if any piece of paper drop inside

  5. #5
    Senior Tech 100+ Posts Service@PRT's Avatar
    Join Date
    Oct 2016
    Location
    Abu Dhabi
    Posts
    127
    Rep Power
    7

    Re: C3520i print issue

    Quote Originally Posted by darkocg88 View Post
    Tried switching fixing film unit, changed belt, drums, cleaned laser. Same result.

    Any help is highly appreciated.

    Br.

    Sent from my Moto E (4) Plus using Tapatalk
    remove transferbelt and Clean the sensor underneath. You can clean it by removing transferbelt and from the leftside of the machine. Clean the 3 sensor.

    Sent from my HUAWEI VNS-L21 using Tapatalk



    Every day of life is a learning process...
    Just make sure you are open in all aspects of comments.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here