Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 7 of 7
  1. #1
    Technician
    Join Date
    Jun 2019
    Location
    muscat
    Posts
    18
    Rep Power
    0

    Question Canon ir c7570i yellow problem

    Hi all,
    Am facing this weird issue with canon ir c7570i where i don't get any yellow color when printing or sometime i get just a little... When i print test page PG10 i get no yellow what so ever (page 3 on the attachment) and when printing PG4 with only yellow i get lines but not the normal gradient color(page 2 on the attachment)... I did check the drum and development drive unites even the laser unit to no vail.. i tried switching the yellow unit with the magenta unit and got full coverage (page 1 on the attachment).
    Patiently waiting for your replys..
    Best regards
    Attached Files Attached Files

  2. #2
    Technical/IT Support 500+ Posts Venom's Avatar
    Join Date
    Nov 2009
    Location
    Ontario
    Posts
    762
    Rep Power
    40

    Re: Canon ir c7570i yellow problem

    the drums wear at rear side and if left long enough it will start pulling developer
    IBM, Mita, Konica Minolta, Ricoh, Kyocera, HyPAS, Canon, Oce, Samsung, HP, TEO IP PBX/Unified Communications, Comptia Network+ Comptia PDI+ Certifications

  3. #3
    Technician
    Join Date
    Jun 2019
    Location
    muscat
    Posts
    18
    Rep Power
    0

    Re: Canon ir c7570i yellow problem

    Quote Originally Posted by Venom View Post
    the drums wear at rear side and if left long enough it will start pulling developer

    Agree ... But however this case is different... I switched the whole yellow drum unit (drum + dev) with the magenta one and got a good yellow output in place of the magenta and no magenta in place of the yellow

  4. #4
    Technical/IT Support 500+ Posts Venom's Avatar
    Join Date
    Nov 2009
    Location
    Ontario
    Posts
    762
    Rep Power
    40

    Re: Canon ir c7570i yellow problem

    The one sample showed yellow bands which looks like a mechanical issue. Maybe the dev unit isn't rotating properly? Write a line with a black marker on both the drum and dev mag roller and see if they are rotating properly. Dev bias losing connection, drum grounding or laser unit could cause light print but isn't likely.
    IBM, Mita, Konica Minolta, Ricoh, Kyocera, HyPAS, Canon, Oce, Samsung, HP, TEO IP PBX/Unified Communications, Comptia Network+ Comptia PDI+ Certifications

  5. #5
    Technician
    Join Date
    Jun 2019
    Location
    muscat
    Posts
    18
    Rep Power
    0

    Re: Canon ir c7570i yellow problem

    Well after several on and off battles with this issue am once again empty handed... Brought another well working machine and started switching every single board to no vail switched all drum drives and developer drives and nothing

    My only option now is to remove and switch the drum holder unit but I can't find how to do so in the manual... So if anyone knows how to i would very much appreciate it

  6. #6
    Field Supervisor 500+ Posts mramlawi's Avatar
    Join Date
    Jul 2011
    Posts
    836
    Rep Power
    34

    Re: Canon ir c7570i yellow problem

    Quote Originally Posted by Asaadahmed003 View Post
    Agree ... But however this case is different... I switched the whole yellow drum unit (drum + dev) with the magenta one and got a good yellow output in place of the magenta and no magenta in place of the yellow

    seems its hv problem or itb problem have u try a new transfer belt and is this problem happen suddenly or after you change toner is ur toner original
    Distinguished road makes you jewel in rough

  7. #7
    Technician
    Join Date
    Jun 2019
    Location
    muscat
    Posts
    18
    Rep Power
    0

    Re: Canon ir c7570i yellow problem

    Quote Originally Posted by mramlawi View Post
    seems its hv problem or itb problem have u try a new transfer belt and is this problem happen suddenly or after you change toner is ur toner original
    We did test it's transfer unit on the other machine and tested the othe machine transfer unit in it still the same. Also we changed all hv boards and the main controller to no vail... The toners are OEM ... We bought the machine as refurbished but when we got it, it had this issue

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here