Results 1 to 5 of 5

Thread: C5100Pro

  1. #1
    Junior Member
    Join Date
    Nov 2019
    Location
    Prince Edward Island
    Posts
    7
    Rep Power
    0

    C5100Pro

    Can anyone tell me what caused all the little bumps on my transfer belt. We just changed the belt cleaning unit and this happened. ricoh belt.jpg It's hard to see with the relection but it looks like the bumps were formed from underneath . Help appreciated before I spend $ on new belt and new cleaning unit.

    Thanks

  2. #2
    Service Manager 2,500+ Posts tsbservice's Avatar
    Join Date
    May 2007
    Posts
    3,023
    Rep Power
    136

    Re: C5100Pro

    Looks like charge rollers inside belt are contaminated with toner clumps. Happens more often when belt/machine maintenance are overdue or/and compatible toners are used. Generally it's time for new image transfer belt unit now but Ricoh aren't exactly in my field expertise so more experienced guys can help better.
    A tree is known by its fruit, a man by his deeds. A good deed is never lost, he who sows courtesy, reaps friendship, and he who plants kindness gathers love.

    Blessed are they who can laugh at themselves, for they shall never cease to be amused.

  3. #3
    Copier Technician 500+ Posts
    C5100Pro

    mga's Avatar
    Join Date
    Dec 2010
    Location
    london
    Posts
    868
    Rep Power
    84

    Re: C5100Pro

    Quote Originally Posted by leonardcahill View Post
    Can anyone tell me what caused all the little bumps on my transfer belt. We just changed the belt cleaning unit and this happened. ricoh belt.jpg It's hard to see with the relection but it looks like the bumps were formed from underneath . Help appreciated before I spend $ on new belt and new cleaning unit.

    Thanks
    Looks like the new belt wasn't installed correctly ie cleaning the unit before the belt was installed best to get ricoh credited service engineer to do

  4. #4
    Service Manager 10,000+ Posts
    C5100Pro

    Phil B.'s Avatar
    Join Date
    Jul 2016
    Location
    Raleigh NC
    Posts
    10,376
    Rep Power
    244

    Re: C5100Pro

    Quote Originally Posted by leonardcahill View Post
    Can anyone tell me what caused all the little bumps on my transfer belt. We just changed the belt cleaning unit and this happened. ricoh belt.jpg It's hard to see with the relection but it looks like the bumps were formed from underneath . Help appreciated before I spend $ on new belt and new cleaning unit.

    Thanks
    why isn't this in the ricoh copier forum?

  5. #5
    Service Manager 2,500+ Posts
    C5100Pro

    copier tech's Avatar
    Join Date
    Jan 2014
    Location
    London
    Posts
    4,943
    Rep Power
    107

    Re: C5100Pro

    Quote Originally Posted by tsbservice View Post
    Looks like charge rollers inside belt are contaminated with toner clumps. Happens more often when belt/machine maintenance are overdue or/and compatible toners are used. Generally it's time for new image transfer belt unit now but Ricoh aren't exactly in my field expertise so more experienced guys can help better.
    This is the key here with a Pro machine, replace ALL parts once they hit PM life or you will run into these kinds of issues.



    Let us eat, drink, and be merry, because tomorrow we may die!

    www.copierfirmware.co.uk

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here