Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Technician
    Riso RP3100UI: Error T05-603

    unwork_inc's Avatar
    Join Date
    Nov 2016
    Location
    Portland, Oregon
    Posts
    43
    Rep Power
    8

    Riso RP3100UI: Error T05-603

    Has anyone ever dealt with a T05-603 error?

    Here's what happened to this machine:


    • A burnt smell came out of the front of the machine upon trying to make a master. The drum didnít seem to be moving at all, resulting in a T05-603 error.
    • The machine was turned off immediately, unplugged and left untouched for a few hours until the smell vanished completely.
    • Upon turning it on and pressing the Start button as per machineís request, the printer started up normally. I thought itíd be wise to remove the drum before doing anything else. After pressing the drum release button I hear the initial movements of the drum prior to being released, but the final horizontal push of the drum didn't occur and the drum remains locked, giving me an T05-603 error again.
    • I unlocked the drum manually and noticed that the smell was coming from the front of the drum. Iíve opened it up and saw that the drum PCB was fried.
    • I put the machine back together, turned it on, insert a different drum, press the Start button again per printerís request and the default 'Ready to Print' appears. But when I press the Test Print button Iím greeted by the same T05-603 error after a few seconds of apparent inactivity.


    As per the technical manual:

    T05-603: The vertical-centering sensor does not switch OFF → ON even when the vertical-positioning pulse motor is moved 12 mm in the ON direction.


    It seems like the fried PCB on the drum has also damaged some of the printerís electrical system but I donít know where to start tracing this error. Any ideas will be greatly received. Iím being paid to fix this machine so if anyone can provide solid results Iíll gladly pass on proper payment.

    Thank you

  2. #2
    Riso dude 250+ Posts jermyth's Avatar
    Join Date
    Mar 2011
    Location
    Land of Diffusion
    Posts
    375
    Rep Power
    25

    Re: Riso RP3100UI: Error T05-603

    I'm guessing you have tried power off, hold the reset button while turning on routine. In start look at the drum connector on the machine and trace it back, look for blown fuse(s). Check voltage on drum pcb and power supply board.
    That's all I can think of at this time.

    Good luck.

  3. #3
    Technician
    Riso RP3100UI: Error T05-603

    unwork_inc's Avatar
    Join Date
    Nov 2016
    Location
    Portland, Oregon
    Posts
    43
    Rep Power
    8

    Re: Riso RP3100UI: Error T05-603

    Thank you for your reply - I did indeed try the procedure you described, I've also replaced all fuses but to no avail.

    I'll have to dig deeper into the machine hoping to find any visual clues that might lead me to the problem.
    Last edited by unwork_inc; 03-16-2018 at 09:06 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here