Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 5 of 5
  1. #1
    Senior Tech 100+ Posts selmila's Avatar
    Join Date
    Aug 2012
    Posts
    131
    Rep Power
    20

    no display C 6501

    hi all.
    C 6501 display dose not light up but the power indicator glows in green. i have checked the control panel it is working in another machine! even the connectors looks good. any suggestions to locate the problem?

  2. #2
    Service Manager 2,500+ Posts
    no display C 6501

    Synthohol's Avatar
    Join Date
    Mar 2016
    Location
    north jersey
    Posts
    3,384
    Rep Power
    117

    Re: no display C 6501

    this may sound stupid but the sub-power switch is on right?

  3. #3
    Senior Tech 100+ Posts selmila's Avatar
    Join Date
    Aug 2012
    Posts
    131
    Rep Power
    20

    Re: no display C 6501

    Quote Originally Posted by Synthohol View Post
    this may sound stupid but the sub-power switch is on right?


    yes the sub-power switch is ON!

  4. #4
    Service Manager 2,500+ Posts
    no display C 6501

    Synthohol's Avatar
    Join Date
    Mar 2016
    Location
    north jersey
    Posts
    3,384
    Rep Power
    117

    Re: no display C 6501

    there are 2 power supplies in the back on the bottom.
    the one behind has some soldered in fuses. check them. had a c6000 with the same symptom until i soldered another fuse in.
    you didnt say if the machine was running or not, just the display is blank. my machine did not run although the power led was green as well.

  5. #5
    Senior Tech 100+ Posts selmila's Avatar
    Join Date
    Aug 2012
    Posts
    131
    Rep Power
    20

    Re: no display C 6501

    [QUOTE=Synthohol;582986]there are 2 power supplies in the back on the bottom.
    the one behind has some soldered in fuses. check them. had a c6000 with the same symptom until i soldered another fuse in.
    you didnt say if the machine was running or not, just the display is blank. my machine did not run although the power led was green as well.[/QUOT


    The display is blank and the machine dose not run the power led is green.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here