I am copy-pasting the thread I opened 3 days ago on fiery forums, just in case you guys have any ideas or you came across this issue before:
It appears that the problem affects all MacOS computers on site
I am facing a weird issue with a Fiery Pro80 (IC-305 v3.0a, System 9) attached on a KM-c6501.

For some reason CWS on MacOS (OS 10.12, cws 5.8) can’t retrieve paper catalogue or tray information from this printer.
Win10, Win7, even the Win XPe on the Pro80 can perfectly fetch this info and set paper from catalog but on mac it’s simply impossible.
3 Mac in total (2 MacPro, 1 xServe) can perfectly see all info, trays, etc on a E-10 (IC-412v1.1) attached on a KM-360, that is also present on the site.
I even tried downgrading the System software to 3.0 and 2.1 but still the same deal.
Have cleaned installed 3 OS (10.10, 10.11, 10.12) in a 3 year period on the Macs, with the problem insisting, so I can exclude faulty/bad install.
Have searched the Fiery Forums, but couldn't find someone with this problem on this configuration.