Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11
    The Wolf 1,000+ Posts mojorolla's Avatar
    Join Date
    Jan 2010
    Location
    C-town
    Posts
    1,800
    Rep Power
    64

    Re: Bizhub C250i Fuser noise

    Quote Originally Posted by Bix View Post
    Hi guys, I have a bizhub C250i installed 1 year ago. This printer is only 30k and started making weird noises from the fusing unit.
    After printing, there is a creaking metal noise for 2-3 seconds. Has anything like this ever happened to you?
    I will order a new fuser but maybe someone knows a possible cause. It sounds like the classic bearing noise.
    Thanks!
    Sounds like the pressure release system from your description. If you run this is service mode, does it make the same noise...?


    Failing to plan is planning to fail!!!

  2. #12
    Senior Tech 100+ Posts avecosat's Avatar
    Join Date
    Jun 2012
    Location
    Valencia
    Posts
    136
    Rep Power
    19

    Re: Bizhub C250i Fuser noise

    I swapped the unit between two machines and stopped making noise .

  3. #13
    Senior Tech 250+ Posts
    Join Date
    Oct 2009
    Posts
    312
    Rep Power
    26

    Re: Bizhub C250i Fuser noise

    This sounds like the classic fuser bearing noise that I've been hearing from everything from the -8 series forward. I usually disassemble and lube the bearings with something called Krytox from DuPont. Quiets them right down. I had one machine with only 10K do this on an -8 series machine.
    OC

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here