Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 8 of 8
  1. #1
    DeLF
    Guest

    LDAP lookups - "Failed to resolve name in DNS server" <- C352s

    Hi all,

    We have several C352 printers and we need to authenticate them against AD. I have spent a long time testing and configuring LDAP to do lookups and each and everytime i click the "Test Connection" button I get the error Failed to resolve name in DNS server.
    I know my DNS setting are correct and both forward and reverse maps resolve perfectly. (The printer has perfect LAN connectivity).

    I am suspecting a firmware bug ?

    Can anyone suggest how to debug this further ? (konica tools ?)

    This is the current firmware dump (i have no clue what the latest is?)

    MFP Controller BOOT Program
    9J06-1E00-G00-01-000(00)
    MFP Controller SubSet Program
    9J06-1F00-G00-02-000(00)
    MFP Controller
    9J06-0100-G00-I8-000(00)
    Operation PANEL Message Data
    9J06-8100-G00-I2-008
    FAX Board Controller1
     FAX Board Controller2
     IR
    9J06-0023-G00-10-000
    PRT
    9J06-0050-G00-20-000
    LPH
     ADF
    9J07-0024-G00-06-000
    Finisher
    9J08-0071-G00-06-000
    System Controller
    9J06-1000-G00-I8-000(00)
    Printer Controller
    9J06-3000-G00-43-000(00)
    Printer Controller-Font
    9J06-3F00-G00-14-000(00)
    Printer Controller-Demo Page
    4037-3E00-G00-00-000
    MIO
    9J06-5000-G00-63-000(00)
    PSWC
    9J06-5100-G00-34-000(00)
    MIB IF
    9J06-5200-G00-20-000(00)
    IPP IF
    9J06-5300-G00-03-000(00)
    External Controller IF
     TCP/Socket
    9J06-6300-G00-00-000(00)
    Open API
    9J06-7000-G00-86-000(00)
    Operation PANEL
    9J06-8000-G00-E0-000(00)
    CSRC
    9J06-8300-G00-02-000(00)
    PIC
    9J06-8200-G00-07-000


    Thanks

    -Alex

  2. #2
    Field Service Manager 1,000+ Posts
    LDAP lookups -  &quot;Failed to resolve name in DNS server&quot; &lt;- C352s

    pepper38_cnd's Avatar
    Join Date
    Aug 2005
    Location
    Windsor, ON Canada
    Posts
    1,073
    Rep Power
    51
    Maybe this will help?
    Attached Files Attached Files
    Online Store is closed. Chip resetting is a thing of the past! Thank you to all my past customers.
    Now into Ip TV KODI Boxes

  3. #3
    DeLF
    Guest
    Quote Originally Posted by pepper38_cnd View Post
    Maybe this will help?
    Thanks, but i have tried all possible configuration possibilities and I still get the error Failed to resolve name in DNS server when clicking "check connection".

    Besides resorting to a packet trace are there any other tools you can recommend to get more debug output than "Failed to resolve name in DNS server." on konica printers ?

    -Alex

  4. #4
    Service Manager 1,000+ Posts
    LDAP lookups -  &quot;Failed to resolve name in DNS server&quot; &lt;- C352s


    Join Date
    Feb 2010
    Posts
    1,987
    Rep Power
    75
    You could try to dump the DNS cache, from what I understand it's harmless and solves a lot of problems.

    But Google it or talk to an IT professional first...

  5. #5
    Konica Minolta Technician 50+ Posts Spidula's Avatar
    Join Date
    Apr 2010
    Posts
    83
    Rep Power
    29
    Latest F/W is K0 for the 352s But I had an LDAP prob with a machine with K0 F/W on. I.T sorted it eventually, but don't know what the fix was!

  6. #6
    Field Supervisor 1,000+ Posts RRodgers's Avatar
    Join Date
    Jun 2009
    Location
    San Bernardino
    Posts
    1,951
    Rep Power
    56
    Quote Originally Posted by Spidula View Post
    Latest F/W is K0 for the 352s But I had an LDAP prob with a machine with K0 F/W on. I.T sorted it eventually, but don't know what the fix was!
    Last time I had a problem with LDAP it turned out to be the time on the copier was off by more than an hour. CHECK the TIME on the copier.
    Color is not 4 times harder... it's 65,000 times harder. They call it "TECH MODE" for a reason. I have manual's and firmware for ya, course... you are going to have to earn it.

  7. #7
    Technician
    Join Date
    Jan 2010
    Location
    Tacoma, wa
    Posts
    25
    Rep Power
    29
    Find out what your AD's server IP is and try connecting directly if flushing your DNS cache doesn't resolve the problem. Also double check that the IT department didn't do anything screwy with their AD server like set SSL or something.

  8. #8
    All things Konica Minolta 1,000+ Posts Stirton.M's Avatar
    Join Date
    Oct 2009
    Location
    Calgary
    Posts
    1,813
    Rep Power
    52
    I agree, use an IP address instead.

    LDAP is for the most part fairly straight forward to configure on these machines. Of the few customers who use it, I have not seen a problem like this.

    And of course, updating the firmware may help some.

    also, the following may provide some insight...

    ---------------------------------------
    Description
    Cannot perform single or multiple character searches in Microsoft® Windows 2003 Active Directory domain.
    Solution
    CAUSE: These engine series ‘Use Referral’ function are not compatible with LDAP \Domain Controller at Domain Functional level of Microsoft® Windows
    2003.
    SOLUTION: Refer attached document to disable 'Use Referral' function.
    ---------------------------------------
    Description
    How to setup LDAP on a C250.
    Solution
    To set up LDAP on a C250, perform the following:
    1. Click on Utility/Counter.
    2. Administrator Setting [12345678], Click OK.
    3. Click on Network Setting.
    4. Click on LDAP Setting.
    5. Enable LDAP to ON and Click OK.
    6. Click on Setting Up LDAP.
    7. Select an Empty Selection BOX.
    8. Enter LDAP Server Name.
    9. Click on FWD &gt;.
    10. Enter Server IP Address. ie.- 11.11.0.2.
    11. Enter Search Base. ie.- dc=kmbs, dc=local .
    12. Click on FWD &gt;.
    13. Enable SSL to OFF, Port No. = 389, Port Number (SSL) = 636.
    14. Click on FWD &gt;.
    15. Select Authentication Method ie.- SIMPLE.
    16. Click on FWD &gt;.
    17. Select Server Authentication Method - Use Set Value.
    18. Use Referral set to OFF.
    19. Click on FWD &gt;.
    20. Enter Login Name ie.- user1.
    21. Enter Password ie.- 1234.
    22. Enter Domain Name. ie.- kmbs.local.
    23. Click on OK, Close, Close, Close, Close, Close.
    24. Reboot copier.
    Troubleshooting Tips:
    1. Ping the Server using the Copier.
    2. Setup the LDAP information given using your Laptop with the Following Software's - PageScope Address Utility or Softerra* LDAP Browser 2.6.
    Notes:
    a. As reference, see the function settings document and How to setup LDAP Setting on MFP Device .
    ---------------------------------------------
    Description
    LDAP does not function after upgrading firmware.
    Solution
    CAUSE: Corrupt firmware.
    SOLUTION: Download the latest firmware version and re-flash the machine.
    --------------------------------------------
    "Many years ago I chased a woman for almost two years, only to discover that her tastes were exactly like mine: we both were crazy about girls."
    ---Groucho Marx


    Please do not PM me for questions related to Konica Minolta hardware.
    I will not answer requests or questions there.
    Please ask in the KM forum for the benefit of others to see the question and give their input.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here