Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 6 of 6
  1. #1
    Senior Tech 100+ Posts
    Join Date
    Aug 2011
    Posts
    129
    Rep Power
    27

    Bizhub C650's and black imaging units

    We've developed an interesting problem with a C650. Within the last 4 months we've gone through 3 black imaging units due to them dumping all of their contents into the back of the copier. Not a fun thing to try and clean out.

    Has anyone else encountered this or know of a solution to this problem? Our assumption at this point is that something happened to them during shipment but the boxes look ok.

    There has been zero problems with the other colors.

  2. #2
    Field Supervisor 500+ Posts
    Bizhub C650's and black imaging units

    minimerlin's Avatar
    Join Date
    Nov 2007
    Location
    Scottish Highlands
    Posts
    851
    Rep Power
    44

    Re: Bizhub C650's and black imaging units

    Quote Originally Posted by ES-OGT View Post
    We've developed an interesting problem with a C650. Within the last 4 months we've gone through 3 black imaging units due to them dumping all of their contents into the back of the copier. Not a fun thing to try and clean out.

    Has anyone else encountered this or know of a solution to this problem? Our assumption at this point is that something happened to them during shipment but the boxes look ok.

    There has been zero problems with the other colors.
    There has been quite a few posts re problems with these units..main cause seems to be poor HV and Bias contacts at the rear due to the locking system not keeping the unit fully positioned. I normally pack out the rubber pads on the lock assembly with cleaning rod pads cut to size! Never shake the IU before fitting and try to keep them level in transit..if possible. There is a mod which is just a plate that is screwed to the frame and holds in the unit if you want!

  3. #3
    Senior Tech 100+ Posts
    Join Date
    Aug 2011
    Posts
    129
    Rep Power
    27

    Re: Bizhub C650's and black imaging units

    Awesome information!! Any way you can get me the part number for the mod?

  4. #4
    Senior Tech 100+ Posts
    Join Date
    Aug 2011
    Posts
    129
    Rep Power
    27

    Re: Bizhub C650's and black imaging units

    Nevermind, we were able to find the fix. Thanks for your help!!

  5. #5
    Service Manager 250+ Posts Ianizer's Avatar
    Join Date
    Jul 2011
    Location
    NW, United States
    Posts
    380
    Rep Power
    32
    Quote Originally Posted by ES-OGT:254593
    Nevermind, we were able to find the fix. Thanks for your help!!
    Care to share??
    -I
    My name Peggy.
    You got problem?

  6. #6
    Field Supervisor 1,000+ Posts RRodgers's Avatar
    Join Date
    Jun 2009
    Location
    San Bernardino
    Posts
    1,951
    Rep Power
    56

    Re: Bizhub C650's and black imaging units

    Quote Originally Posted by Ianizer View Post
    Care to share??
    -I
    Maybe he installed the mod?
    Color is not 4 times harder... it's 65,000 times harder. They call it "TECH MODE" for a reason. I have manual's and firmware for ya, course... you are going to have to earn it.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here