Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 9 of 9
  1. #1
    Senior Tech 250+ Posts
    Join Date
    Feb 2008
    Posts
    408
    Rep Power
    30

    Bizhub 283 SMTP Server Connection Problems

    We recently installed a Biz283 that I am having problems getting connected to the customer's SMTP server. The customer is using a Linux-based email server, running PostFix, and located about 1000mi away. I have confirmed scan-to-email functionality using Gmail before I installed the machine, so I am confident that the machine is in good working order. At present, the copier is connecting to the PostFix server, giving the "EHLO printer.corp.blahblahblah", but disconnecting right afterwards. From the copier side, all I see are that scan jobs are faulting out with a "forward tx error". I have not seen the server logs myself, but their Admin tells me that there is no other information other than that our copier is disconnecting directly after EHLO. He also mentioned that the copier is using ESMTP, rather than SMTP, and wanted to know if that was changeable. I've never seen any mention of ESMTP in KM literature, so I am doubtful that there are any settings related to it.

    The machine has been programmed with credentials that (I am told by customer's IT, anyways) have been given permissions on the server. No way that I can confirm for myself.

    I am having some difficulty getting information from the company regarding proper security settings for their server, and still think this problem is related to that. Unfortunately, I have little experience with Linux, and zero experience with PostFix. Are there any methods that I am unaware of to further troubleshoot this connection issue? I was really hoping to garner a little more information from the server's logs, but as it stands I have very few clues to go on.

    Thanks in advance,

  2. #2
    jonjrl
    Guest

    Re: Bizhub 283 SMTP Server Connection Problems

    Quote Originally Posted by 907tec View Post
    We recently installed a Biz283 that I am having problems getting connected to the customer's SMTP server. The customer is using a Linux-based email server, running PostFix, and located about 1000mi away. I have confirmed scan-to-email functionality using Gmail before I installed the machine, so I am confident that the machine is in good working order. At present, the copier is connecting to the PostFix server, giving the "EHLO printer.corp.blahblahblah", but disconnecting right afterwards. From the copier side, all I see are that scan jobs are faulting out with a "forward tx error". I have not seen the server logs myself, but their Admin tells me that there is no other information other than that our copier is disconnecting directly after EHLO. He also mentioned that the copier is using ESMTP, rather than SMTP, and wanted to know if that was changeable. I've never seen any mention of ESMTP in KM literature, so I am doubtful that there are any settings related to it.

    The machine has been programmed with credentials that (I am told by customer's IT, anyways) have been given permissions on the server. No way that I can confirm for myself.

    I am having some difficulty getting information from the company regarding proper security settings for their server, and still think this problem is related to that. Unfortunately, I have little experience with Linux, and zero experience with PostFix. Are there any methods that I am unaware of to further troubleshoot this connection issue? I was really hoping to garner a little more information from the server's logs, but as it stands I have very few clues to go on.

    Thanks in advance,
    Smtp enable
    Here is the info to make SMTP Authentication work.



    1. Login Admin mode on MFP panel.

    2. Select Admin2.

    3. Open "SoftSW setting" and set "SoftSW 380, Bit6=1 and Bit2=1".

    4. Save Settings

  3. #3
    Field Supervisor 2,500+ Posts
    Join Date
    Jun 2009
    Posts
    3,020
    Rep Power
    88

    Re: Bizhub 283 SMTP Server Connection Problems

    I believe you are thinking of the older bizhubs (200,350 ect) that by default did not support smtp authentication..the 283 supports SSL/TSL, authentication, and multiple ports..My 1st step would be to try and ping the server from the MFP, at least you can confirm that you are able to communicate with it. Not familiar with Linux so no help there.., but for an exchange server that is giving me fits, the next thing would be to try and Telnet the ports they are saying to use..

    If the above works, then the next step would be to try different configurations in an attempt to see some sort of change..from "Server connect" to login failure..You may have to use different ports, turn on SSL/TSL, try putting the domain name in front of the login user name. (should not be needed if the domain name is set under TCP/IP settings)..Try the IP address versus the smtp name to rule out a DNS issue. KMBS does not support 3rd party mail providers...meaning if you can make it work, joy, but if not, really big shame..I have had success with gmail, verizon, brighthouse, but have never made "go daddy" work. Emujo

  4. #4
    Senior Tech 250+ Posts
    Join Date
    Feb 2008
    Posts
    408
    Rep Power
    30

    Re: Bizhub 283 SMTP Server Connection Problems

    Thanks for your help guys. It would appear that the customer's IT staff was finally able to resolve this one on their own. Part of the problem I was having was that the customer has separate people for User/Administrator issues, for SMTP issues, and for IT Help Desk issues. Once the SMTP guy took a look at the settings, he saw the problem: his server doesn't use SMTP Auth. whodathunkit. Lesson learned: if you are having SMTP problems, demand to speak with the SMTP server Admin directly and not through an intermediary.

    Also learned: Enabling SMTP authorization (of any type) can result in the mfp disconnecting from SMTP servers directly after "EHLO", giving a "forward TX" error for the scan job.

  5. #5
    Field Supervisor 1,000+ Posts
    Bizhub 283 SMTP Server Connection Problems

    TheOwl's Avatar
    Join Date
    Nov 2008
    Posts
    1,739
    Rep Power
    54

    Re: Bizhub 283 SMTP Server Connection Problems

    You can also get a Forward TX Error if you have Start over TLS enabled when the SMTP server doesn't use SSL/TLS.
    Please don't ask me for firmware or service manuals as refusal often offends.

  6. #6
    Senior Tech 250+ Posts
    Join Date
    Feb 2008
    Posts
    408
    Rep Power
    30

    Re: Bizhub 283 SMTP Server Connection Problems

    Funny you should mention that: The customer's IT dept. originally told me that they had an Exchange email server, so I had the machine setup as such. There are some documents in the KM SSD that mention using Start TLS for Exchange SMTP.

  7. #7
    Field Supervisor 1,000+ Posts
    Bizhub 283 SMTP Server Connection Problems

    TheOwl's Avatar
    Join Date
    Nov 2008
    Posts
    1,739
    Rep Power
    54

    Re: Bizhub 283 SMTP Server Connection Problems

    Use this for Exchange. Get around having to play around with security settings on the machine and only takes about 30 secs to do.

    Email with Exchange 2010.pdf
    Please don't ask me for firmware or service manuals as refusal often offends.

  8. #8
    Trusted Tech 50+ Posts morpk's Avatar
    Join Date
    Oct 2010
    Location
    Gold Coast
    Posts
    97
    Rep Power
    0

    Re: Bizhub 283 SMTP Server Connection Problems

    My rule of thumb is start with a from address and a SMTP server IP and if that dosent work start building around that no use adding user auth if the server doesn't require it before you know it too many option are enabled and you are chasing your feet trying to fix an issue.

  9. #9
    Field Supervisor 1,000+ Posts
    Bizhub 283 SMTP Server Connection Problems

    TheOwl's Avatar
    Join Date
    Nov 2008
    Posts
    1,739
    Rep Power
    54

    Re: Bizhub 283 SMTP Server Connection Problems

    Just re-read the original post and thought I would clarify ESMTP:

    SMTP (Simple Mail Transfer Protocol) is used for transferring email messages between computers where as ESMTP (Enhanced Simple Mail Transfer Protocol) adds enhancements to the base SMTP protocol such as security and authentication.

    If you Telnet into any current Microsoft Exchange Server, you will get a message looking similar to:

    220 servername.domain.com Microsoft ESMTP MAIL Service, Version: (what ever the version of Exchange is) ready at (the date, time and timezone of connection).

    Microsoft Exchange from 2007 and onwards uses TLS as part of the standard receive connector (receive connectors are basically rules that define where email is allowed to be accepted from and what sort of security the other end must use in order to get a connection to that connector).

    The document that I attached earlier describes how to create an un-authenticated SMTP Relay connector (remember that copiers use SMTP Relaying) to which devices can connect to for sending email so long as they are included in the list of the allowed IP addresses. Back in the day, this was known as whitelisting an IP address.

    Now the whitelisting part is probably the clue that you are looking for when it comes to your Linux SMTP server. It might be that the Linux server holds a whitelist of email addresses or IP addresses which are allowed to send email. The other thing is that the SMTP server might be a SMTP Gateway which basically filters everything coming through on port 25 and then hands the information that is deemed to be ok to an Exchange server.

    The easiest way to determine this is to ask a user if you can open up the account settings from their email client such as Outlook, Thunderbird and so on. Those account details will then give you the name or IP address of the server that the users use to send email through.
    Please don't ask me for firmware or service manuals as refusal often offends.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here