Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17
  1. #11
    Trusted Tech 50+ Posts kjg's Avatar
    Join Date
    Mar 2009
    Location
    Currently in a small town, TN. Originally from Michigan
    Posts
    96
    Rep Power
    26

    Re: TA 520i Image issues

    Try changing both the transfer roller assembly and the drum input guide that comes in the maintenance kit. Both have caused me that grief in the past on multiple 420's and 520's.

  2. #12
    Trusted Tech 50+ Posts
    Join Date
    Jun 2019
    Location
    gauteng
    Posts
    71
    Rep Power
    7

    Re: TA 520i Image issues

    Quote Originally Posted by kjg View Post
    Try changing both the transfer roller assembly and the drum input guide that comes in the maintenance kit. Both have caused me that grief in the past on multiple 420's and 520's.

    Drum input guide ?

  3. #13
    Trusted Tech 50+ Posts
    Join Date
    Jun 2019
    Location
    gauteng
    Posts
    71
    Rep Power
    7

    Re: TA 520i Image issues

    Quote Originally Posted by kjg View Post
    Try changing both the transfer roller assembly and the drum input guide that comes in the maintenance kit. Both have caused me that grief in the past on multiple 420's and 520's.


    Drum input guide ? do you maybe have a photo to send me ?

    thank you

  4. #14
    Trusted Tech 50+ Posts kjg's Avatar
    Join Date
    Mar 2009
    Location
    Currently in a small town, TN. Originally from Michigan
    Posts
    96
    Rep Power
    26

    Re: TA 520i Image issues

    Parts Guide Transfer, 302GR94481. In parts manual page 11 Item A03. It comes in the maintenance kit. It sits just below the drum between the drum and the transfer roller and is held in with a single screw. You will need to remove the drum to replace it.
    It usually has a yellow sticker on it warning users not to touch the drum surface.

  5. #15
    Senior Tech 100+ Posts
    TA 520i Image issues

    copydocinc's Avatar
    Join Date
    Mar 2015
    Location
    Bountiful, Utah
    Posts
    239
    Rep Power
    17

    Re: TA 520i Image issues

    The spacing of these smudges looks like possible fuser unit.

  6. #16
    Trusted Tech 50+ Posts
    Join Date
    Jun 2019
    Location
    gauteng
    Posts
    71
    Rep Power
    7

    Re: TA 520i Image issues

    Quote Originally Posted by copydocinc View Post
    The spacing of these smudges looks like possible fuser unit.

    thank you , I will keep that option in mind as i am heading back to the client on Monday to try the above mentioned options and if that fails will definitely look at replacing fuser

    thank you all i will give feedback once i have been to the client

  7. #17
    Trusted Tech 50+ Posts
    Join Date
    Jun 2019
    Location
    gauteng
    Posts
    71
    Rep Power
    7

    Re: TA 520i Image issues

    Thank you all for the help and advice
    i have sorted the issue out , i replaced the the transfer roller and the transfer roller holders and springs as the one holder was broken and the spring missing

    after replacing the roller and holders and springs even the copy quality looked alot better


    once again thank you for the suggestions

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here