Results 1 to 10 of 10

Thread: 4002i: C2840

  1. #1
    Senior Tech 100+ Posts RandyW's Avatar
    Join Date
    Jan 2013
    Posts
    183
    Rep Power
    24

    4002i: C2840

    We looked at a Copystar CS-4002i that has a C2840 error code. We had not looked at the machine before. No idea on service history.

    It didn't look like there was much if any toner in the waste toner container. Also appeared that they were using aftermarket toner. Thought the primary transfer unit looked like it had copies on it. Nothing appeared obviously damaged on it.

    If we read the meter correctly, it has 1.2 million pages on the machine. I don't know what the story is with that but I doubt they have made that many pages on it themselves...it's being used by a restaurant.

    Tried to do some motor tests using U030 but they didn't turn. Our tech said he went down the list of them but none would make noises. I thought that was weird (I believe it did make some mechanical noises of some kind when turned on). I saw on here 906 mentioned in a thread. I believe it just said to reboot machine and had same code when it was turned back on.

    Waste toner motor? Primary Transfer assy? Waste toner motor behind some boards in the back? Service manual was hard to tell 100% but looked like you have take off covers in the back and swing out a board assembly to access that.

  2. #2
    Owner/Service Manager 1,000+ Posts
    4002i: C2840

    tmaged's Avatar
    Join Date
    Oct 2008
    Location
    Center of my Universe
    Posts
    1,763
    Rep Power
    60

    Re: 4002i: C2840

    Check the connector on the top of the belt that mates to the connector on the frame. Likely a bent pin there or not making a good connection. It should try to do something when powered on.
    Hope that helps !
    -Tony


    www.dtios.com
    Become a fan on Facebook

  3. #3
    Senior Tech 250+ Posts
    4002i: C2840


    Join Date
    Aug 2008
    Location
    Seattle
    Posts
    284
    Rep Power
    41

    Re: 4002i: C2840

    Belt cleaning motor is suspect for C2840 not waste toner motor. It is located on the transfer belt assembly.

    QA I168.pdf

    There is another bulletin H243 that explains a torn off seal that gets caught inside the transfer belt cleaning unit causing the code.

  4. #4
    Field Supervisor 500+ Posts
    Join Date
    Dec 2020
    Location
    VALRIC, FL
    Posts
    620
    Rep Power
    31

    Re: 4002i: C2840

    When you remove the fuser check and clean the spike grid that is behind it .

  5. #5
    Senior Tech 100+ Posts RandyW's Avatar
    Join Date
    Jan 2013
    Posts
    183
    Rep Power
    24

    Re: 4002i: C2840

    welp replaced the transfer assy with a new one. Good news, bad news.

    Code went away- printing blank now. I believe there is no image on the belt.

  6. #6
    Senior Tech 100+ Posts RandyW's Avatar
    Join Date
    Jan 2013
    Posts
    183
    Rep Power
    24

    Re: 4002i: C2840

    U030- belt release motor didn't seem to make any noise.


    Does that do something with putting the transfer belt assy in contact with the drum? Trying to read about that in the service book. Also part of the 302NK93022 drive unit?

  7. #7
    Senior Tech 100+ Posts RandyW's Avatar
    Join Date
    Jan 2013
    Posts
    183
    Rep Power
    24

    Re: 4002i: C2840

    grey plastic pin!

    Locking shaft is that what it is called. I guess wasn't pushed in all the way.
    4002i dv unit.jpg

  8. #8
    Owner/Service Manager 1,000+ Posts
    4002i: C2840

    tmaged's Avatar
    Join Date
    Oct 2008
    Location
    Center of my Universe
    Posts
    1,763
    Rep Power
    60

    Re: 4002i: C2840

    Sometimes they quit locking. I just put a plastic screw in them to keep them going.
    Hope that helps !
    -Tony


    www.dtios.com
    Become a fan on Facebook

  9. #9
    Senior MFP Technician 250+ Posts ihatefinishers13's Avatar
    Join Date
    Feb 2020
    Location
    US
    Posts
    250
    Rep Power
    15

    Re: 4002i: C2840

    Quote Originally Posted by tmaged View Post
    Sometimes they quit locking. I just put a plastic screw in them to keep them going.
    A typical cheap Kyocera design, cheap, barely works, and fails randomly. I usually just put some thick paper or cardboard backing folded a few times, and it does the trick.

  10. #10
    Field Supervisor 500+ Posts
    Join Date
    Oct 2012
    Posts
    653
    Rep Power
    35

    Re: 4002i: C2840

    I think you will get this code when the comb electrode behind the fuser gets dirty also?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here