Page 1 of 2 12 LastLast
Results 1 to 10 of 20
  1. #1
    Multibrands Tech 250+ Posts rapidocument's Avatar
    Join Date
    Jul 2012
    Location
    Los Angeles, CA.
    Posts
    320
    Rep Power
    19

    Ricoh Aficio MP301 with SC672

    Hi guys

    Got this little machine Ricoh MP-301 showing SC672
    As per the manual I checked the Controller board and Dimms but still the same

    The machine warms up and produces some (5, 6 copies) but no more and then stalls.

    Any other idea is welcomed.
    Thanks,

  2. #2
    Trusted Tech 50+ Posts jeff33's Avatar
    Join Date
    Aug 2009
    Location
    spicewood
    Posts
    61
    Rep Power
    21

    Re: Ricoh Aficio MP301 with SC672

    HDD if it has one

  3. #3
    Multibrands Tech 250+ Posts rapidocument's Avatar
    Join Date
    Jul 2012
    Location
    Los Angeles, CA.
    Posts
    320
    Rep Power
    19

    Re: Ricoh Aficio MP301 with SC672

    This model doesn't have HDD.

  4. #4
    Technician
    Join Date
    Feb 2011
    Posts
    27
    Rep Power
    18

    Re: Ricoh Aficio MP301 with SC672

    Faxboard?

  5. #5
    Field Supervisor 500+ Posts Zeldaman's Avatar
    Join Date
    Mar 2011
    Location
    Stuttgart/Baden Wuerttemberg
    Posts
    858
    Rep Power
    35

    Re: Ricoh Aficio MP301 with SC672

    Hi there!
    Check the connectors & cables from controller/LCD-screen, and very important. a complete fw-update.
    Greetings...

  6. #6
    Service Manager 2,500+ Posts
    Ricoh Aficio MP301 with SC672

    copier tech's Avatar
    Join Date
    Jan 2014
    Location
    London
    Posts
    3,585
    Rep Power
    66

    Re: Ricoh Aficio MP301 with SC672

    I had the exact same fault it was the controller board.
    Check to see if theres other sc errors in the history, mine had sc802 I believe
    Let us eat, drink, and be merry, because tomorrow we may die!

    www.copierfirmware.co.uk

  7. #7
    Service Manager 1,000+ Posts bob marley's Avatar
    Join Date
    Jan 2012
    Posts
    1,134
    Rep Power
    32

    Re: Ricoh Aficio MP301 with SC672

    Check the condition of the operation panel and its connector
    Live for yourself and you will live in vain. Live for others, and you will live again

  8. #8
    Geek Extraordinaire 2,500+ Posts KenB's Avatar
    Join Date
    Dec 2007
    Location
    Cleveland, Ohio
    Posts
    3,086
    Rep Power
    78

    Re: Ricoh Aficio MP301 with SC672

    Quote Originally Posted by rapidocument View Post
    This model doesn't have HDD.
    It's an option, and required for certain functions.
    Some days you’re the dog, some days you’re the fire hydrant.

  9. #9
    Trusted Tech 50+ Posts
    Join Date
    May 2011
    Location
    cleveland
    Posts
    70
    Rep Power
    17

    Re: Ricoh Aficio MP301 with SC672

    Quote Originally Posted by Zeldaman View Post
    Hi there!
    Check the connectors & cables from controller/LCD-screen, and very important. a complete fw-update.
    Greetings...
    I'm having same issue the only thing I haven't t ried is op-panel and harnesses. I found part number for op-panel and usb harness but not the grey wiring harness that goes to BICU. I scoured the parts manual. did any of you order both harnesses? if so do you know the numbers? Thanks

  10. #10
    Senior Tech 250+ Posts
    Join Date
    Feb 2011
    Location
    Phoenix, Arizona
    Posts
    292
    Rep Power
    21

    Re: Ricoh Aficio MP301 with SC672

    We've had two of them do the same thing and both times replacing the fax board took care of it. SC672's can be very tricky to troubleshoot. Take the fax out of it and see if it still codes. My guess is it won't. Hope this helps.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here