Results 1 to 7 of 7
  1. #1
    Technician
    Join Date
    Jul 2017
    Location
    Comifornia
    Posts
    11
    Rep Power
    6

    Pro C5110s Toner Cart

    Hey guys, Having a very interesting issue. The unit has new toners installed but here is the problem, The machine is saying that the K & Y are empty..then flashes and says ALL toners not set correctly, re set toners. It keeps flipping between the two. Ive switched the toners for new, re-seated the toners, toner hopper, drum plate, ALL electrical connectors from the TSB board and main controller. Im at a lost for what is happening. Im not ricoh small format cert and only have access to wide-format on the ricoh site to get firmware. I do have all the TSBs put out and one does mention Firmware to 1.45 for a toner issue.

    Anyone run into this issue before?

  2. #2
    Retired 10,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    10,867
    Rep Power
    253

    Re: Pro C5110s Toner Cart

    Could you fill in more information in your profile. Like where you are from.

  3. #3
    Senior Tech 100+ Posts
    Join Date
    Aug 2012
    Posts
    223
    Rep Power
    19

    Re: Pro C5110s Toner Cart

    Sounds like your PCB's are toast which read the toner chips

    Replace all 4 as a set

    I have this issue before a couple of times but each time has been a different issue

    Other things were sub hopper was gone

    Last one was toner drive gear was seized

    Would start with the PCB's though

  4. #4
    Copier Technician 100+ Posts
    Pro C5110s Toner Cart

    mga's Avatar
    Join Date
    Dec 2010
    Location
    london
    Posts
    228
    Rep Power
    29

    Re: Pro C5110s Toner Cart

    Quote Originally Posted by Bricorley View Post
    Hey guys, Having a very interesting issue. The unit has new toners installed but here is the problem, The machine is saying that the K & Y are empty..then flashes and says ALL toners not set correctly, re set toners. It keeps flipping between the two. Ive switched the toners for new, re-seated the toners, toner hopper, drum plate, ALL electrical connectors from the TSB board and main controller. Im at a lost for what is happening. Im not ricoh small format cert and only have access to wide-format on the ricoh site to get firmware. I do have all the TSBs put out and one does mention Firmware to 1.45 for a toner issue.

    Anyone run into this issue before?
    Are you using oem toner also in the UK you can access all models on the my ricoh website

  5. #5
    Service Manager 2,500+ Posts
    Pro C5110s Toner Cart

    copier tech's Avatar
    Join Date
    Jan 2014
    Location
    London
    Posts
    4,084
    Rep Power
    79

    Re: Pro C5110s Toner Cart

    Quote Originally Posted by Bricorley View Post
    Hey guys, Having a very interesting issue. The unit has new toners installed but here is the problem, The machine is saying that the K & Y are empty..then flashes and says ALL toners not set correctly, re set toners. It keeps flipping between the two. Ive switched the toners for new, re-seated the toners, toner hopper, drum plate, ALL electrical connectors from the TSB board and main controller. Im at a lost for what is happening. Im not ricoh small format cert and only have access to wide-format on the ricoh site to get firmware. I do have all the TSBs put out and one does mention Firmware to 1.45 for a toner issue.

    Anyone run into this issue before?
    Interesting issue as you can replace the toners on the Pro while the machine is running.

    What firmware version are you on?

    If you are using genuine toners i'd start by updating the firmware.
    Let us eat, drink, and be merry, because tomorrow we may die!

    www.copierfirmware.co.uk

  6. #6
    Technician
    Join Date
    Jul 2017
    Location
    Comifornia
    Posts
    11
    Rep Power
    6

    Re: Pro C5110s Toner Cart

    Quote Originally Posted by Imprestik View Post
    Sounds like your PCB's are toast which read the toner chips

    Replace all 4 as a set

    I have this issue before a couple of times but each time has been a different issue

    Other things were sub hopper was gone

    Last one was toner drive gear was seized

    Would start with the PCB's though
    Replaced to Toner PCB on the toner assembly and updated firmware to current. Same issue. Ill try the full toner set next

    Quote Originally Posted by copier tech View Post
    Interesting issue as you can replace the toners on the Pro while the machine is running.

    What firmware version are you on?

    If you are using genuine toners i'd start by updating the firmware.
    I flashed firmware to 1.50 this A.M.

  7. #7
    Technician
    Join Date
    Dec 2009
    Location
    adelaide
    Posts
    30
    Rep Power
    0

    Re: Pro C5110s Toner Cart

    Quote Originally Posted by Bricorley View Post
    Hey guys, Having a very interesting issue. The unit has new toners installed but here is the problem, The machine is saying that the K & Y are empty..then flashes and says ALL toners not set correctly, re set toners. It keeps flipping between the two. Ive switched the toners for new, re-seated the toners, toner hopper, drum plate, ALL electrical connectors from the TSB board and main controller. Im at a lost for what is happening. Im not ricoh small format cert and only have access to wide-format on the ricoh site to get firmware. I do have all the TSBs put out and one does mention Firmware to 1.45 for a toner issue.

    Anyone run into this issue before?

    Any SC codes generated ?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here