Page 1 of 2 12 LastLast
Results 1 to 10 of 13
  1. #1
    Junior Member
    Join Date
    Sep 2018
    Posts
    4
    Rep Power
    0

    DSC428 admin/supervisor passwords not working

    Hello, I'm trying to set IP address and other settings of an DSC428. Here the printer interface wants me to login since otherwise these operations are denied.


    So I tried login as admin/admin or admin/blank and also supervisor/blank and administrator/blank and other variations. The supervisor login works (on the machine and also the webinterface). However after saving the new admin passwort the changes seem to not take effect (I did not miss the second apply button).


    I also tried to reset the addressbook which was not working vie SP-Mode.


    I dumped the NV ram the find out the passwords like in ( Lost supervisor password? ) however I don't want to risk damaging anything so I have not tried loading a reseted NV file back into the printer.

    The administrator seems to have an empty password (which is not working). And the format seems to not exactly match (not 4 byte between "marker" and username).
    ScreenshotDump.jpg

    I also tried decoding the admin password (which was also not working)
    k /
    d P u c 6 6 6 6

    I would appreciate any tips how to gain access back, thanks for your attention.

  2. #2
    Senior Tech 100+ Posts DRichard's Avatar
    Join Date
    May 2008
    Location
    Knoxville, TN
    Posts
    214
    Rep Power
    29

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by fritz.net View Post
    Hello, I'm trying to set IP address and other settings of an DSC428. Here the printer interface wants me to login since otherwise these operations are denied.


    So I tried login as admin/admin or admin/blank and also supervisor/blank and administrator/blank and other variations. The supervisor login works (on the machine and also the webinterface). However after saving the new admin passwort the changes seem to not take effect (I did not miss the second apply button).


    I also tried to reset the addressbook which was not working vie SP-Mode.


    I dumped the NV ram the find out the passwords like in ( Lost supervisor password? ) however I don't want to risk damaging anything so I have not tried loading a reseted NV file back into the printer.

    The administrator seems to have an empty password (which is not working). And the format seems to not exactly match (not 4 byte between "marker" and username).
    ScreenshotDump.jpg

    I also tried decoding the admin password (which was also not working)



    I would appreciate any tips how to gain access back, thanks for your attention.
    Have you ried the Factory Service Mode (the one you use if you need to reenter the machine's ser#)? If you can get there, try using SP5-846-046.

  3. #3
    Retired 10,000+ Posts slimslob's Avatar
    Join Date
    May 2013
    Location
    Bakersfield, CA
    Posts
    12,647
    Rep Power
    316

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by fritz.net View Post
    Hello, I'm trying to set IP address and other settings of an DSC428. Here the printer interface wants me to login since otherwise these operations are denied.


    So I tried login as admin/admin or admin/blank and also supervisor/blank and administrator/blank and other variations. The supervisor login works (on the machine and also the webinterface). However after saving the new admin passwort the changes seem to not take effect (I did not miss the second apply button).


    I also tried to reset the addressbook which was not working vie SP-Mode.


    I dumped the NV ram the find out the passwords like in ( Lost supervisor password? ) however I don't want to risk damaging anything so I have not tried loading a reseted NV file back into the printer.

    The administrator seems to have an empty password (which is not working). And the format seems to not exactly match (not 4 byte between "marker" and username).
    ScreenshotDump.jpg

    I also tried decoding the admin password (which was also not working)



    I would appreciate any tips how to gain access back, thanks for your attention.
    My experience has been that the procedure in that thread only works with older B/W models.

  4. #4
    Junior Member
    Join Date
    Sep 2018
    Posts
    4
    Rep Power
    0

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by DRichard View Post
    Have you ried the Factory Service Mode (the one you use if you need to reenter the machine's ser#)? If you can get there, try using SP5-846-046.
    Thanks for your reply.
    I've read about the factory Service mode, but did not find how to access it (only the hint to search for it - but i only found the "classic" SP Mode). When i go to SP5-846 i miss the numbers between 10 and 47 so there is no 46.

    Quote Originally Posted by slimslob View Post
    My experience has been that the procedure in that thread only works with older B/W models.
    Thanks for your information. Sounds like bad news

  5. #5
    Senior Tech 100+ Posts DRichard's Avatar
    Join Date
    May 2008
    Location
    Knoxville, TN
    Posts
    214
    Rep Power
    29

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by fritz.net View Post
    Thanks for your reply.
    I've read about the factory Service mode, but did not find how to access it (only the hint to search for it - but i only found the "classic" SP Mode). When i go to SP5-846 i miss the numbers between 10 and 47 so there is no 46.


    Thanks for your information. Sounds like bad news
    How to access this version of service mode has been posted elsewhere on this site (by others who weren't very concerned about making it public). It works fine on all current models of Ricoh MFPs.

  6. #6
    Senior Tech 100+ Posts
    Join Date
    Sep 2012
    Location
    Turin
    Posts
    248
    Rep Power
    23

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by fritz.net View Post
    Thanks for your reply.
    I've read about the factory Service mode, but did not find how to access it (only the hint to search for it - but i only found the "classic" SP Mode). When i go to SP5-846 i miss the numbers between 10 and 47 so there is no 46.


    Thanks for your information. Sounds like bad news

    Can you send me the dump of NVRAM?
    I may be able to decrypt those passwords

  7. #7
    Technician
    Join Date
    Jul 2019
    Posts
    25
    Rep Power
    3

    DSC428 admin/supervisor passwords not working

    That service mode will reset all the data back to factory
    And delete the address book


    Sent from my iPhone using Tapatalk

  8. #8
    Service Manager 2,500+ Posts
    DSC428 admin/supervisor passwords not working

    sandmanmac's Avatar
    Join Date
    Feb 2009
    Location
    Toronto, ON
    Posts
    3,185
    Rep Power
    108

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by bmwmick View Post
    That service mode will reset all the data back to factory
    And delete the address book
    Incorrect.
    SP5-846-046 ONLY resets Supervisor credentials and address book.
    I run it with every single machine that I re-sell

  9. #9
    Senior Tech 100+ Posts DRichard's Avatar
    Join Date
    May 2008
    Location
    Knoxville, TN
    Posts
    214
    Rep Power
    29

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by sandmanmac View Post
    Incorrect.
    SP5-846-046 ONLY resets Supervisor credentials and address book.
    I run it with every single machine that I re-sell
    This is correct. After performing this particular mode, you are prompted to power the machine off/on. At next power on you will see the screen prompting you to enter new passwords. you will also find Addressbook Data has been deleted. I know of no other data loss.

  10. #10
    Service Manager 2,500+ Posts
    DSC428 admin/supervisor passwords not working

    sandmanmac's Avatar
    Join Date
    Feb 2009
    Location
    Toronto, ON
    Posts
    3,185
    Rep Power
    108

    Re: DSC428 admin/supervisor passwords not working

    Quote Originally Posted by DRichard View Post
    This is correct. After performing this particular mode, you are prompted to power the machine off/on. At next power on you will see the screen prompting you to enter new passwords. you will also find Addressbook Data has been deleted. I know of no other data loss.
    I must admit, that I just cross-referenced this model to Ricoh to find out exactly what the discussion was about.
    I didn't realize that we were travelling all the way back in time to an Aficio 3228C!
    In the end, I'm fairly sure this process, and some others, don't apply to a model that old

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here