Like Slim said, if settings aren't being applied when printing, I would go into "user tools" --> "Printer features" --> "system" --> "Tray Priority" -- > and set bypass to "Driver/ Command".

I would also double check the bypass type settings. go into "user tools" --> "System settings" --> "tray paper settings" --> down a page to "bypass paper type" and set for cardstock and Thick 3.

Do you know what the counts are on your Drum and Development units? Have you done a Color Calibration yet? "User tools" --> Maintenance --> Auto Color Calibration (Should be one for copier and 3 or 4 for printer).