Thanks Thanks:  0
Likes Likes:  0
Dislikes Dislikes:  0
Results 1 to 3 of 3
  1. #1
    Technician
    Join Date
    May 2017
    Location
    Leeds
    Posts
    13
    Rep Power
    0

    ColorQube 9303 pre-heater rolling pump

    Hi, as suggested in another thread, I ordered a pre-heater for my ColorQube as it had the 089-520 error. Unfortunately the replacement part which arrived has a missing rolling pump.

    Could anybody suggest anything about moving the pump over to the new part.

    Also the reason why I was suggested to get a new part was because it supposedly had sensor cap debonded which does not seem to be the case.

    Maybe if it is not the cap, it is something else? What could it be? Can I assemble one working part from two non-working parts?

    Please anybody with any remote ideas chip in.

    Thank you in advance!

    20191129_105750.jpg
    Last edited by kurbads; 2 Weeks Ago at 11:43 AM.

  2. #2
    Senior Tech 100+ Posts
    ColorQube 9303 pre-heater rolling pump


    Join Date
    May 2014
    Posts
    195
    Rep Power
    13

    Re: ColorQube 9303 pre-heater rolling pump

    Quote Originally Posted by kurbads View Post
    Hi, as suggested in another thread, I ordered a pre-heater for my ColorQube as it had the 089-520 error. Unfortunately the replacement part which arrived has a missing rolling pump.

    Could anybody suggest anything about moving the pump over to the new part.

    Also the reason why I was suggested to get a new part was because it supposedly had sensor cap debonded which does not seem to be the case.

    Maybe if it is not the cap, it is something else? What could it be? Can I assemble one working part from two non-working parts?

    Please anybody with any remote ideas chip in.

    Thank you in advance!

    20191129_105750.jpg
    The rolling pump was deleted in later pre-heater models! Plug the new pre heater assembly in and away you go!

    If you look closely you will see the newer unit has a series of springs to pressure the plates. Much improved.

    This has lead to funny service calls where the tech has assumed someone stole a part out of the machine! I have seen people get quite upset after being accused of losing it! lol.

    Sent from my SM-T530NU using Tapatalk

  3. #3
    Senior Tech 100+ Posts
    ColorQube 9303 pre-heater rolling pump


    Join Date
    May 2014
    Posts
    195
    Rep Power
    13

    Re: ColorQube 9303 pre-heater rolling pump

    Quote Originally Posted by kurbads View Post
    Hi, as suggested in another thread, I ordered a pre-heater for my ColorQube as it had the 089-520 error. Unfortunately the replacement part which arrived has a missing rolling pump.

    Could anybody suggest anything about moving the pump over to the new part.

    Also the reason why I was suggested to get a new part was because it supposedly had sensor cap debonded which does not seem to be the case.

    Maybe if it is not the cap, it is something else? What could it be? Can I assemble one working part from two non-working parts?

    Please anybody with any remote ideas chip in.

    Thank you in advance!

    20191129_105750.jpg
    As for it not being the cap... it could be any of the associated gear train. Exactly why the piece is spared as a whole and not as individual plastic pieces. It could also be a weak pre heater motor.

    Sent from my SM-T530NU using Tapatalk

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here