Results 1 to 4 of 4
  1. #1
    Junior Member
    Join Date
    Aug 2020
    Location
    Jonesboro, AR
    Posts
    3
    Rep Power
    0

    D-125 not printing clean on lead and tail edge

    We have 2, and 1 is down. The 1 that is running, is not printing clean on the lead edge, and worse on the tail. We've cleaned the toner dust, toner is at 28%, changed the cleaner roll, and tomorrow we're trying replacing the drum. Can anyone give me a hint of something else to try, before replacing the drum?
    Thanks in advance!
    R Jeffers

  2. #2
    Service Manager 5,000+ Posts
    D-125 not printing clean on lead and tail edge

    Phil B.'s Avatar
    Join Date
    Jul 2016
    Location
    Raleigh NC
    Posts
    9,473
    Rep Power
    218

    Re: D-125 not printing clean on lead and tail edge

    Quote Originally Posted by Rjeffers View Post
    We have 2, and 1 is down. The 1 that is running, is not printing clean on the lead edge, and worse on the tail. We've cleaned the toner dust, toner is at 28%, changed the cleaner roll, and tomorrow we're trying replacing the drum. Can anyone give me a hint of something else to try, before replacing the drum?
    Thanks in advance!
    R Jeffers

    hire a trained xerox tech...

  3. #3
    Senior Tech 250+ Posts
    D-125 not printing clean on lead and tail edge


    Join Date
    Feb 2008
    Posts
    259
    Rep Power
    33

    Re: D-125 not printing clean on lead and tail edge

    Based on this and your other post, I would also suggest you hire a tech. I know nobody wants to because of the fairly high and potentially open-ended cost, but if you're not experienced in these machines, the types of problems you are having are not particularly DIY-able.

    Unless you happen to be trained or experienced, if your car starts acting up, you take it to a mechanic. If your AC goes out, you call an HVAC company.

    And these copiers are in many ways, more complex inside than either cars or AC units.

  4. #4
    Service Manager 5,000+ Posts
    D-125 not printing clean on lead and tail edge

    Phil B.'s Avatar
    Join Date
    Jul 2016
    Location
    Raleigh NC
    Posts
    9,473
    Rep Power
    218

    Re: D-125 not printing clean on lead and tail edge

    Quote Originally Posted by Caffeine View Post
    Based on this and your other post, I would also suggest you hire a tech. I know nobody wants to because of the fairly high and potentially open-ended cost, but if you're not experienced in these machines, the types of problems you are having are not particularly DIY-able.

    Unless you happen to be trained or experienced, if your car starts acting up, you take it to a mechanic. If your AC goes out, you call an HVAC company.

    And these copiers are in many ways, more complex inside than either cars or AC units.
    +1 A G A I N ...


    this guy doesn't have a clue the OP i mean, Caffeine

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here