PDA

View Full Version : C253 FW black screen hell...


Custom Search


fishleg
02-15-2011, 09:42 PM
Hi,
Just had an absolute nightmare at a customers what turned from a routine FW while I was there turned horribly bad..

So put the firmware on the compact flash put it into machine switched on just black screened me. I then took the card out thought nothing of it restarted machine and just did the exact same just a black screen lights on the copier light up but it refuses to boot.

I have heard of this in the past I think its a corrupt boot rom caused by bad/wrong firmware just wondering how I can recover the machine ? Would an NVRam reset the bootrom then allow me to firmware it again ?

I'm going back tomorrow with NVRAM, MFP, NVRAM reset tool, R5/R6 firmwares. Not sure what happened to cause it tho so any insight would be grateful.

Thanks for any help,
Fishy

aesthetics1
02-16-2011, 01:46 AM
Pull off the back cover and see if you have any angry red lights flashing at you.

This could be a number of things. You could have simply knocked loose one of the external cables connecting to the right side of the machine, above where you insert the firmware card.

Bad DIMMs on the OACB can cause this.

Bad firmware can cause this.

Bad NVRAM can cause this.

Try and do the simple stuff first. I would recommend checking the cables, then the DIMMs since they are quick and easy, the firmware next, and then try resetting the NVRAM, and lastly swapping the NVRAM altogether (You might get a license management error if you swap the NVRAM, [happens occasionally when you swap OACBs too] which is semi-annoying to fix, that's why this is last on the list.)

Good luck!

fishleg
02-16-2011, 11:03 PM
Great its the mfp board ><. Tried swapping just the nvram first no luck even tried booting up the reset tool no luck.

Any bright ideas how I can recover the mfp ? All it does at the moment is the machine powers up and the blue and orange lights just stay on just below the platen with the screen blank.

Cheers,
Fishy

aesthetics1
02-18-2011, 05:17 PM
I wouldn't say that it's indeed the MFP board just yet.

Try eliminating the less costly parts first.

Swap the memory from a known good machine as suggested before. Try swapping the touch panel.

Albonline
02-18-2011, 09:18 PM
flash it again. use a known good flash

fishleg
02-19-2011, 09:05 AM
Well I think I'm screwed its definitely not the memory as the board was fine until me trying to flash it.

I tried a working firmware that I tried on another machine next to it but it will not work. All I get with or with out a compact flash inserted is the two indicator lights come on and thats it the machine gets no further.

On a working machine the two indicator lights come on for around 4 seconds then go off then the machine boots up but with mine they never go off so its definitely goosed.

Must be a way to reinitialise the mfp. Why the heck did they choose compact flash lol.

I think I've corrupted the bootrom as I think as soon as you insert the cf card it updates that so since it never completed its shagged. I cant believe there's not a work around tho as surely you think just reflash it but not in this case ><.

huntergazz
02-21-2011, 12:37 PM
Hi,

I had a similar issue with a 203, I replaced the mfp board then when I loaded the f/w it took an age to boot up again. It turned out that the version of the f/w I had was out of date. I downloaded the K9 f/w and have had no issues since.

mabawser
02-21-2011, 12:59 PM
The only way the mfp is recoverable is if the machine had a certain level of firmware that can allow you to recover it but at this minute of time I couldnt tell you what level that was (sorry) had firmware issues last week. Was told that if the machine has level ?*? then I could have recovered it.

Sorry I cant remember what level it is.

fishleg
02-21-2011, 07:20 PM
I guess theres not a chance in hell of recovering it if it wont even boot ><.

Tried loads of different firmwares no luck with any I dont think its coming back to life unless theres something I'm missing ?

aesthetics1
02-22-2011, 05:08 PM
Have you done the NVRAM Recovery tool? That's a small file also loaded using the CF card and almost always fixes this issue.

fishleg
02-22-2011, 10:44 PM
Same thing even the nvram tool doesnt boot the machine. All I get is the two indicator lights solid just to the left of the screen and thats it ><.

aesthetics1
02-22-2011, 10:53 PM
I think you have a loose interface cable (as I mentioned in my previous posts) or a dead OACB. Check the cables before you replace your board.

fishleg
02-22-2011, 11:01 PM
I will try that but that doesn't explain how if its working until you insert a flash card then it goes off on one.

I don't think its loose cables because I used all the old parts in the new board to rule them out so nvram, memory are definitely ok. The trouble board is now in our workshop in another machine that was used to fix the other at the customers and it has the exact same symptoms as when it was in the customers machine. So its 100% the mfp cant be anything else.

I cant explain it really if I some how duffed the firmware some how but all I got was a black screen not the usual firmware screen. I know it takes a few mins to pop up but this was 20 mins before I pulled the plug on it.

I'm surprised it doesn't always boot from compact flash i.e. if you had a power cut on older machines they would always boot in a mode ready to receive firmware. The c253 I guess if something happens or you got bad fw / card your screwed ><.

fishleg
07-16-2012, 08:41 PM
Bump - Had another machine like this today updating fw causing machine to become unresponsive. The last machine machine I had do this the only thing that fixed it was a new mfp board. Has anyone had a similar problem or know of a fix other than a mfp :P ?

So machine was working on R5 FW so it was updated to R6 which was successful on reboot the machines two leds light up but never fully boots up as if the machine is stuck in standby mode no sandglass just a blank screen a initial fan noise when its first switched on.

Tried diff nvram, nvram recovery card it will not flash firmware as the machine never gets to the firmware screen.

Any ideas ?

PeterG
07-17-2012, 07:52 AM
I had it happen on a C451. No fault reported, the boss just wanted me to update the f/w. A perfectly working C451, one minute later, a "toaster".
I did nothing wrong, followed procedures exactly. Friggin KM and their crap f/w.
Bye the way. Try explaining to your customer, why you 'fixed" their copier and now it doesn't work at all.
It was the MFP board by the way. All 2 Grand of it.

SmellsHot
07-17-2012, 08:56 PM
How long are you waiting after you insert the CF card for firmware?
I've had some machines, take over 5 minutes just to bring up the firwmare screen.

Custom Search