Results 1 to 5 of 5
  1. #1
    Junior Member
    Join Date
    Aug 2015
    Posts
    7
    Rep Power
    0

    Sharp MX-3570 Operation Panel blank

    Hi guys! Need help!

    Sharp MX-3570N - Operation panel is blank, but copier boots normally and if you tap the place on the Operation Panel where "Copy" icon resides the copier makes copies.
    When you print from PC - it prints. Web page of the copier is accessible as well. It just Oper Panel that gives problem.

    Operation panel ass'y and LVDS PWB replaced
    Flat cable from MFPC to LVDS PWB replaced.
    Harness from MFPC to LVDS - replaced
    MFPC board - replaced
    DС PWB - replaced
    Fuser F10 next to CN33 on MFPC - OK

    Still no effect. Operation Panel stays blank

    Any ideas?
    Thanks in advance!

  2. #2
    Senior Tech 100+ Posts
    Join Date
    May 2010
    Location
    Dallas, TX
    Posts
    229
    Rep Power
    22

    Re: Sharp MX-3570 Operation Panel blank

    was this a new LVDS board or one from Hytec? we had one that was bad from Hytec. Same symptom.

  3. #3
    Junior Member
    Join Date
    Aug 2015
    Posts
    7
    Rep Power
    0

    Re: Sharp MX-3570 Operation Panel blank

    Quote Originally Posted by repn1999 View Post
    was this a new LVDS board or one from Hytec? we had one that was bad from Hytec. Same symptom.

    It was the board from the working identical machine. Same model.

  4. #4
    Senior Tech 100+ Posts moose55's Avatar
    Join Date
    Mar 2017
    Location
    Papillion, NE
    Posts
    126
    Rep Power
    6

    Re: Sharp MX-3570 Operation Panel blank

    Msata card?
    The Moose is loose!!

  5. #5
    Junior Member
    Join Date
    Jun 2019
    Location
    west Allis, Wisconsin
    Posts
    2
    Rep Power
    0

    Re: Sharp MX-3570 Operation Panel blank

    Quote Originally Posted by chatkal View Post
    Hi guys! Need help!

    Sharp MX-3570N - Operation panel is blank, but copier boots normally and if you tap the place on the Operation Panel where "Copy" icon resides the copier makes copies.
    When you print from PC - it prints. Web page of the copier is accessible as well. It just Oper Panel that gives problem.

    Operation panel ass'y and LVDS PWB replaced
    Flat cable from MFPC to LVDS PWB replaced.
    Harness from MFPC to LVDS - replaced
    MFPC board - replaced
    DС PWB - replaced
    Fuser F10 next to CN33 on MFPC - OK

    Still no effect. Operation Panel stays blank

    Any ideas?
    Thanks in advance!
    SCN MFPC PWB CN33 P38 CCFT is back light which goes to CN1 P3 of LVDS PWB, if everything works but no light check this. Then check CN 5 P7 of LVDS PWB to CN5 P6 of LCD

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-=-=-=-=-=-


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here