PDA

View Full Version : Miscellaneous Ricoh scans to email, Konica and Lexmark DO NOT


Custom Search


ITMOSTLY
03-02-2016, 10:15 PM
I have a customer that has scan to email setup on 4 MFDs, 1 Konica Minolta C364e, 2 Lexmark XM3150 and 1 Ricoh (unsure of the model), and all have been working fine for months. These 4 devices are all on the same subnet (192.168.1.xxx). Then the other day out of the blue the Konica Minolta and the 2 Lexmarks quit working. They appear to be trying to connect to the server but after the time-out period lapses I receive a server connection error. On the other hand the Ricoh has been scanning fine all along. All these devices are configured the same using the same email server, smtp.gmail.com, same port, 465 w/ssl enabled, and same authenticating gmail account with allow less secure apps turn on. I have looked at the configuration on the Ricoh and made all the same setting in the other 3 machines to no avail, they don't work. I have physically moved one Lexmark to where the Ricoh is and used the Ricoh’s external hardware (network cable and path to internet, ports, switches, routers and even the IP address from the Ricoh) with thesame result: server connection error. I am thinking, what is this Ricoh copier doing that the other 3 are not doing or is this problem outside of these machines in their network (firewalls/routers configuration)? Any comments or suggestions would be greatly appreciated.

LNorris
03-02-2016, 10:17 PM
don't know anything about Konicas or Lexmarks, but did you check DNS? I think it has to be 8.8.8.8 to work with google.

ITMOSTLY
03-02-2016, 10:30 PM
Thanks for asking, but DNS settings are all the same in all 4 copiers.

Mr Spock
03-03-2016, 02:14 AM
On the Konica delete any self signed certificates and then try.

NeoMatrix
03-03-2016, 04:22 AM
I assume print,scan and ping commands work successfully across all machines ?
Common to all 4 machines the RICOH might be on fixed IP address while the 3 other faulty machine are on DHCP ?

First impression it sounds like a hardware routing or switch error ? A simple ping would confirm all ok.
I assume you have reset(power down) the router or network switch used by all the MFD's ?

Could be a certificate out of date, which means the time/date of the MFD's may be incorrect.
Did the fault happen on/after February 29th accounting for the leap year time/date format ?

ITMOSTLY
03-03-2016, 04:33 PM
The printing is working across all 4 machines and they all have fixed/static IP addresses. As a temporary solution, on the 3 non-emailing copiers, I have successfully setup SMB scanning to a shared folder on a server drive. I do not believe there are any SMTP self-signed certificates on the 3 devices. I tried using a cert on the Konica and received the same erring result and have since removed the cert. I have not power cycled any routers or switches and don't know if I can get that accomplished as this is a very busy downtown Chicago hotel. I will take that advice and see if I can get that done though. Thank you very much. I have setup scanning through gmail account on various MFDs probably over 100 times and never ran across a problem I can't resolve. This one has me really stumped. The fact these 3 machines all quit at the same time and are from 2 different manufactures tends to make me believe that it is something external from the copiers. To answer your leap day question: this happened at least 2 weeks before leap day. I have checked all the dates in these copiers.

Thank you for your feedback and any other future thoughts you have will be accepted with great appreciation.

scanmc
03-03-2016, 06:36 PM
If they stopped scanning to Gmail I would check the firmware version. Gmail recently made some changes on their side and we experienced this on some of the Muratecs a couple of weeks back and the firmware upgrade cured the problem

copyrooks
03-03-2016, 06:55 PM
Try pinging the smtp address from the Bizhub. See if successful or not. If not successful i would start looking at contacting the cust's IT dept to see if they restricted the copiers from contacting the outside. If their IT is anything like the ones i deal with its gunna be a looooooooong day. good luck

copier tech
03-03-2016, 07:34 PM
Keeping the firmware up to date seems to help. Google have a habit of changing various security settings etc

allan
03-03-2016, 07:47 PM
Just to check if the machines does have permission on the network use a different smtp server (non-google).
That should work.

Does the 3 machines have anything in the description and text body of the emails?
But its not connecting?? so don't think that is it.

allan
03-03-2016, 07:52 PM
The KM machine should also give you an error code under job log details.

ex smtp error 57 "the socket is not connected".
All these are in the service manual.

That could give a clue to what is wrong.

qbert69
03-03-2016, 11:06 PM
https://support.google.com/a/answer/176600?hl=en

Instead of using--> aspmx.l.google.com

Use--> 74.125.138.27

-OR-

smtp.gmail.com --> 74.125.21.108

Also, make sure IPV6 is disabled on the mfp's--first time I Ping'd aspmx.l.google.com from my terminal program in windows 7, it gave a weird address, so I disabled IPV6 and it returned the above.

I have had instances where an MFP wouldn't resolve the domain name to the IP address and it would time out...in that case, I just used the direct IPV4 Address, which almost always works!

Good Luck!

:cool:

ITMOSTLY
03-04-2016, 12:03 AM
I am able to successfully ping the gmail server from the Konica. After scanning the doc the Konica's active log shows sending for 60 seconds which is the SMTP timeout setting, it almost seems like the copier is getting out to the server, but there is no reply back to the copier. I have tried to convince their IT person that these replies are being block coming back in from the server but cannot prove these thoughts. I have already had twoooooooo looooooooooong days there.

The error code on the Konica is: 107 Service Manual: Server Connection Error.

IP V6 is disabled on all 3 copiers.

Thank you all for all the suggestions.

SmellsHot
03-04-2016, 02:13 PM
Use google's email IP to eliminate any DNS issues. 74.125.202.109
This has fixed some random scan to email issues for me

EarthKmTech
03-04-2016, 09:45 PM
I have already had twoooooooo looooooooooong days there.



We charge $275 an hour for IT issues, the customer usually suddenly finds alternative methods acceptable when faced with this.

B0265
03-07-2016, 11:37 AM
From the end of last year Google only accept SHA-2 cerificates, on the Bizhub delete the current certificate and create a new using SHA-256 encryption.

Albonline
03-07-2016, 02:16 PM
From the end of last year Google only accept SHA-2 cerificates, on the Bizhub delete the current certificate and create a new using SHA-256 encryption.


this should fix your issue.

NeoMatrix
03-08-2016, 01:59 AM
From the end of last year Google only accept SHA-2 cerificates, on the Bizhub delete the current certificate and create a new using SHA-256 encryption.

I'm not up to date with current hashing algorithms so people may like to do an internet search (SHA-2) for their own peace of mind. The SHA-2 certificates and hash algorithms are suppose to be more secure. Some of the older encryption Hashing algorithms have issues. No doubt SHA-2 security will change in the future when computers become faster yet again. There is other hash algorithms like SHA-384, SHA-512 which supposedly provide increased security.

It's interesting how the hardware and software infrastructure integrates over time. Everyone must move with the times or get left behind. I for one certainly cannot keep up with the technology changes.

If it wasn't for forums like CTN the relevant information wouldn't make it out to where it is required.

copier tech
03-08-2016, 09:43 AM
i've not come across this issue yet, but for future reference could someone provide instructions on how to create this certificate please?

Custom Search