PDA

View Full Version : Stuck toner processing unit on C6500


Custom Search


adeyemi
02-24-2017, 10:29 PM
Why is the processing unit (I mean that unit that holds the devs, drums, chargers and drums) on this C6500 always so very difficult to pull out, as if it is stuck inside. I have replaced the processing unit itself as well as the rails, but does not resolve the issue. I'm sure someone out there must have experienced this somewhere. Pls help

Synthohol
02-24-2017, 11:51 PM
you do drop the ADU handle first?


if the belt drums and DV units are out is it just as difficult?
if not, install 1 unit at a time until resistance is greater than ideal.
if yes maybe the connector/housing is off a bit

adeyemi
02-25-2017, 12:40 AM
you do drop the ADU handle first?


if the belt drums and DV units are out is it just as difficult?
if not, install 1 unit at a time until resistance is greater than ideal.
if yes maybe the connector/housing is off a bit

Thanks for your response. Actually I did something like what you suggested and it seem to boil down to the yellow and black drum positions (not the drums themselves because if switched, still remains that way). Just that I was wondering what could be holding it down at those points?

Synthohol
02-25-2017, 12:58 AM
ok, maybe the shafts are warped/bent/misaligned/angry because the coronas get most of the attention?

methogod
02-25-2017, 06:11 AM
we had a bent interlock (the "safety" that prevents the ADU and the process unit from being pulled out at the same time.

Just by pass the interlock system. Not sure if that's your issue, but fix out problem.

Custom Search