PDA

View Full Version : Sc 621 On Sr950


Custom Search


ryanking001
10-15-2007, 11:47 PM
Hi guys do you have any Ideas? the machine is logging sc621 in the smc, the finisher remains dead! I have replaced bicu psu and controller on the finisher, checked motors and wiring!!!!!!:eek:

blackcat4866
10-16-2007, 03:12 AM
It sounds like you have a nice dead short somewhere. This is the fast & dirty way to troubleshoot this:

Disconnect finisher to confirm that the code disappears. (This does not necessarily mean the BICU is detecting errors correctly, but its a good sign).

If the error vanishes. Then connect the main cable to the copier. At the finisher controller disconnect all connectors. Power up. No error? Good.

Connect the 24VDC supply voltage connector only. Power up. No error? Good. Is the LED lit on the finisher controller? Good.

One by one reconnect each connector until your error reappears, or the finisher becomes dead again. Disregard other finisher errors (because you unplugged everything), just watch for the SC621 communication error.

When you find that one connector that kills everything, track it down from there. A good candidate is the stapler harnass. Ricoh has had a problem with these for a while.

wings
05-16-2008, 11:48 AM
Hi guys do you have any Ideas? the machine is logging sc621 in the smc, the finisher remains dead! I have replaced bicu psu and controller on the finisher, checked motors and wiring!!!!!!:eek:

Hi, an old one!
but replace the switches that detect the finisher

Custom Search