PDA

View Full Version : Mita DC-1656


Custom Search


Sgt. Hulka
06-25-2005, 07:02 PM
I\'m working on an old Mita DC1656 that keeps having the same problem every 4 months or so. The main PCB gets zapped with static and the thing starts making copies that look like checkerboards. I can reset it with sim 70 and reload all the data but it keeps coming back. Years ago I remember a mod that had you cut a wire on the front of the machine from the blank lamp assembly and tie it to ground. I remember it was a yellow wire but that was 15 years ago there are a few yellow wires. anyone have any info other then, \"throw it out\"?

KJ1110
06-29-2005, 06:36 PM
I don\'t remember any such mod; I\'ve still got all of the tech bulletins and there\'s nothing like that in there!

I do remember something somewhat along those lines for the old DC-152z series, but not for that symptom!

Sorry!

dqydj
07-06-2005, 02:06 AM
I had simular problems with some of the mita\'s but I don\'t
remember having that problem with that model.
Anyway the main charger would arch to the frame above it
causing a logic dump. I would start by replacing the entire
mc carona with the unit that came with the dc-1855 (it\'s a modified
version of the 1656 carona with a grid.) and
I would also put electrical tape on the frame above
the mc carona. had alot of the dc 4086 having this problem.
also the older mitas get the more wierd electrical problems they have.
the boards don\'t age gracefully. hope this helps.

Custom Search