PDA

View Full Version : Dead Machine C550- no display, no warm up, hourglass screen.


Custom Search


pager727
08-05-2014, 04:12 PM
So about 3 weeks ago I received a call about a dead C550- no display not warming up... could not figure it out. 2 days later customer called and said "it just started working" he then canceled the call. About a week later it happened again. One of the other techs I work with suggested to unhook the HDD and see if it changes anything- no such luck. I found a tech pub that said it could be the memory modules, I replaced those with no effect at all. But if I switch the positions of the existing modules I can get the display to come up but it is unresponsive. No buttons-no touchscreen. I don't believe I need to replace the display because if I hold "utility/counter" I can get the black dot but then it just sits on the hourglass screen until it shuts down, No trouble reset comes up. I thought it might be firmware, but again I am foiled. Every chip I use says Error This is invalid card please make sure card. Any help would be great, thanks in advance

Nelo
08-15-2014, 01:16 PM
Hi, from my view I believe its firmware, as you mentioned about the card reading as wrong memory, which is not. I have a bulliten that says its actually the wrong firmware that's on the card. Find the correct firmware and load it on to the card using the firmware imaging tool kit to formate and load firmware, then try loading the firmware again. I am quite sure its a firmware issue. If this doesn't work try swapping ram and HD with working ones to confirm faulty ram or to HD.

Thanks.

douglasdouglasv
08-16-2014, 12:33 AM
Possibly the hard drive. I had several Minolta machines "hourglass" 75 percent it was the hdd.

Jazzwcs
08-17-2014, 05:48 PM
Make sure that the cf card you're using for firmware is formatted as FAT and not NTFS. If it is giving you that error afterwards then you are looking at a NVRAM problem and will have to either try recovering it or replacing it.

Russ
08-28-2019, 11:13 PM
Greetings

I came into the office where I have a C550. I obtained it from a client who was replacing it. I haven't needed to use it for a while.

Looking at the machine, it has the hourglass on it.

Power down, leave unplugged, etc., and turn back on, the same thing comes up.

I tried to go to the Service Manual Section to find one, but it seems all people do there is post links to PORN advertising sites so they can get their cash etc.

My guess is the HD has failed, or, there may have been a power outage and the Firmware has become corrupted. I have made a contribution just so that I wasn't seen as a troll.

PLEASE don't delete. Any chance someone has the files/utilities I need to be able to disassemble and replace drive, as well as possibly flash the firmware. I know I have a CF card somewhere.

Any help would be appreciated.

Russ

Custom Search