C3350 image unit installation error

Collapse
X
 
  • Time
  • Show
Clear All
new posts
  • Brett GS
    Trusted Tech
    100+ Posts
    • Jun 2013
    • 154

    C3350 image unit installation error

    Hi all
    I got two C3350 brand new machines.
    Out of box they giving image unit installation error.
    Only thing is it doesnt say which color unit is missing.
    Tried swopping units between another machine,updating the firmware and checked the contact pins and all seem fine.
    Any suggestion?

    Thanks
    Brett
  • Albonline
    Service Manager
    1,000+ Posts
    • Sep 2008
    • 1056

    #2
    Re: C3350 image unit installation error

    Originally posted by Brett GS
    Hi all
    I got two C3350 brand new machines.
    Out of box they giving image unit installation error.
    Only thing is it doesnt say which color unit is missing.
    Tried swopping units between another machine,updating the firmware and checked the contact pins and all seem fine.
    Any suggestion?

    Thanks
    Brett
    Think, but not sure that the factory installed image units do not have chips. so swapping wont have much effect if you are using the ones from new copiers.

    Comment

    • Albonline
      Service Manager
      1,000+ Posts
      • Sep 2008
      • 1056

      #3
      Re: C3350 image unit installation error

      also, look very closely at the units, have had a few come in with broken boards and no apparent external damage.

      Comment

      • floody
        Technician
        • Mar 2017
        • 37

        #4
        Re: C3350 image unit installation error

        might be worth reseating the transfer unit?

        Comment

        • MVPunisher
          Trusted Tech
          Site Contributor
          100+ Posts
          • May 2013
          • 207

          #5
          Re: C3350 image unit installation error

          Any solution to this? MFP board?

          Comment

          • D Colour
            Trusted Tech
            Site Contributor
            100+ Posts
            • Oct 2008
            • 203

            #6
            Re: C3350 image unit installation error

            Don't suppose anyone knows what the solution to this was? This morning we have a C3350 showing "Imaging Unit Installation Error."

            Haven't been out to the machine yet, just asked the user to reseat all units, but error message still present.

            Thanks

            James
            Everything that has a beginning, has an end.....

            Comment

            Working...