View Full Version : Olivetti dCopia 45

Custom Search

05-30-2008, 07:20 PM
i got a problem with an Olivetti machine, i think it is a kyocera behind but I dont know the exact model number.
I had mounted a 20GB hard disk inside and now the harddisk fails. I tried to put in another one, but it doesn't work. I think it could be an issue with the capacity, so I limited the 60GB drive to 32GB but it doesn't work.

In my opinion it i necessary to format the hard drive before you are able to format it with the systemtools of the copier system. My problem is, that i have no glue what file system is used in this machine. I should be some kind of unix but I can't find any further information about it. So if anyone knows please inform me about that.

Thanks a lot afore for you hints an hopefully I get it done, because the spare disk offerd from olivetti costs about 300 and that is too much for a 20GB drive.

Best regrets,

05-31-2008, 02:36 AM
I just downloaded the operators manual. The US equivalent is the KM-6030/ KM-8030. There are some obvious differences.

The copy speed is bumped up from 45 cpm to 60 or 80 cpm. The toner hopper is entirely different (yours is more like a Canon toner hopper), and the internal paper decks have been installed in the bottom two slots instead of the top two slots.

The optional hard drive for the KM model is 40GB. I've not tried this out, but there are references here to using laptop hard drives. Take a look at the following link: http://www.copytechnet.com/forums/kyocera-mita-copystar/7294-kyocera-km-3035-a.html


06-01-2008, 07:24 PM
thanks for the tip, I already read this thread. In this machine the harddrive is a 3,5" disk from Seagate (ST320014A) with special pads for earth connection.

The problem is I cant check it out, because I have to send the new formatted disk to a technician 700km west. So it should work properly. Can anybody please check the file system of the drive. I guess it should be HFS or another unix compliant system.

Thanks in advance for all further information


06-02-2008, 11:33 PM
hm, what a pity. If no one got a solution for this I give a try an report back after testing because i have to send it tomorrow.


06-03-2008, 12:51 AM
If you're open to wild-ass guesses:

I'd install the hard drive, with front door open power on, enter service mode, format hard drive, power off/on.

If you can get into service mode without erroring out, it will probably work.

Please let me know how it goes.


06-03-2008, 06:02 AM
It's a Kyocera-Mita KM-4530


07-22-2008, 10:35 AM
hi people,

i tested a lot and didn't get it working. So I bought the original drive. After that I took a look on the filesystem and the settings of the original one.
Then I put the same settings to a new unformatted harddrive an stuck it into the copier and now guess?- it didn't work. I've no idea what they do to the harddrives but if I have some spare time i will check out whats the "magic" about the original harddrive for 300 bugs :eek:

greetz from austria

Custom Search