Results 1 to 9 of 9
  1. #1
    Technician carlsson's Avatar
    Join Date
    Apr 2021
    Location
    Boras
    Posts
    32
    Rep Power
    7

    Impossible to get smtp to work [Canon C351]

    My brother in law got hold of a used C351, and I have helped him to install it.
    However, it's effing impossible to get the machine to send emails with the scan to mail function! It tries for a bit, and then ends with an error (#933 if I recall correctly, which means nothing the list I looked at).


    I have a C5235 myself, and that works just as it should. I set up the C351 exactly the same, to no avail. Seriously, this should not be that hard.


    So, some questions:
    1. Since this is a used machine there may be some settings that I have overlooked. Is there a way to factory reset the machine without destroying anything important (like calibration etc) ?
    2. It's extremely tiresome to try a setting, restarting and wait for the result. Why in heavens name did Canon not just create a "Test SMTP settings" functions? Or is there?
    3. Any ideas on where to look without a reset?
    4. I have looked for a newer firmware, but the Canon site says that "I have the newest version". How does it know that, I have not given any info about the machine...? Where can I find the newest firmware?



    Device Basic Information
    Manufacturer : CANON INC
    Device Name : iR-ADV C351P
    Location :
    Product Name : iR-ADV C351
    Serial Number : QNV05xxx
    Version Information
    Main Board Version : 9
    Controller Version : 4101.0.2101


    Any help would be highly appreciated, I'm quite stuck.

  2. #2
    Senior Tech 250+ Posts
    Impossible to get smtp to work [Canon C351]

    techandtrader's Avatar
    Join Date
    Jun 2016
    Location
    Oklahoma City OK
    Posts
    311
    Rep Power
    22

    Re: Impossible to get smtp to work [Canon C351]

    I would run the Init all data so the interface is all set back to default. Always a good idea on a newly acquired box.
    I have used Canon Imagerunner parts for sale. Most are floor model Color and / Advances Imagerunner with some 3025 3235 parts. Several intact machines being parted.

  3. #3
    Senior Tech 100+ Posts
    Impossible to get smtp to work [Canon C351]

    Saturn's Avatar
    Join Date
    Nov 2023
    Location
    Frankfurt/Germany
    Posts
    102
    Rep Power
    5

    Re: Impossible to get smtp to work [Canon C351]

    Quote Originally Posted by carlsson View Post
    My brother in law got hold of a used C351, and I have helped him to install it.
    firmware, but the Canon site says that "I have the newest version". How does it know that, I have not given any info about the machine...? Where can I find the newest firmware?
    The latest Firmware is v41.02.03, Date 2023.03.07. You can find the firmware in the Canon SIMS portal. However, only registered Canon technicians have access to that.

  4. #4
    Senior Tech 250+ Posts alex@wocltd.com's Avatar
    Join Date
    Nov 2007
    Posts
    430
    Rep Power
    38

    Re: Impossible to get smtp to work [Canon C351]

    firmware wont make any difference - if you 5 series is working fine do an export via rui after doing an init data - alternatively set up scan to folder?

  5. #5
    Senior Tech 100+ Posts Hart's Avatar
    Join Date
    Feb 2024
    Location
    Boulevard Périphérique
    Posts
    113
    Rep Power
    7

    Re: Impossible to get smtp to work [Canon C351]

    I don't know Canon but maybe the model is too old and can't use TLS 1.2 (or whatever version your SMTP is using) ?

  6. #6
    Trusted Tech 50+ Posts
    Join Date
    Jun 2019
    Location
    Terrace BC
    Posts
    62
    Rep Power
    10

    Re: Impossible to get smtp to work [Canon C351]

    sometimes one of the encryptions is left unchecked on the older models but is needed for the certain scan to email/network.

    settings/registration, preferences, network, TLS.

    Check the encryptions and the allowable tls versions.

    I'm assuming the port is okay.

    Print out the settings/registration, preferences, output report and just check everything.

  7. #7
    Service Manager 5,000+ Posts
    Impossible to get smtp to work [Canon C351]

    copier tech's Avatar
    Join Date
    Jan 2014
    Location
    London
    Posts
    7,552
    Rep Power
    182

    Re: Impossible to get smtp to work [Canon C351]

    Quote Originally Posted by carlsson View Post
    My brother in law got hold of a used C351, and I have helped him to install it.
    However, it's effing impossible to get the machine to send emails with the scan to mail function! It tries for a bit, and then ends with an error (#933 if I recall correctly, which means nothing the list I looked at).


    I have a C5235 myself, and that works just as it should. I set up the C351 exactly the same, to no avail. Seriously, this should not be that hard.


    So, some questions:
    1. Since this is a used machine there may be some settings that I have overlooked. Is there a way to factory reset the machine without destroying anything important (like calibration etc) ?
    2. It's extremely tiresome to try a setting, restarting and wait for the result. Why in heavens name did Canon not just create a "Test SMTP settings" functions? Or is there?
    3. Any ideas on where to look without a reset?
    4. I have looked for a newer firmware, but the Canon site says that "I have the newest version". How does it know that, I have not given any info about the machine...? Where can I find the newest firmware?



    Device Basic Information
    Manufacturer : CANON INC
    Device Name : iR-ADV C351P
    Location :
    Product Name : iR-ADV C351
    Serial Number : QNV05xxx
    Version Information
    Main Board Version : 9
    Controller Version : 4101.0.2101


    Any help would be highly appreciated, I'm quite stuck.
    You've not said how far you have got troubleshooting, I trust you have confirmed the basic connections are correct, gateway & DNS etc? I usually turn on DHCP to allow the device to pull all the network settings.

    Do you know how to check / change the SMTP port number on this device? (in service mode)

    We can supply the latest firmware, if you've tried the above.




    Let us eat, drink, and be merry, because tomorrow we may die!

    For all your firmware & service manual needs please visit us at:

    www.copierfirmware.co.uk - www.printerfirmware.co.uk




  8. #8
    Technician carlsson's Avatar
    Join Date
    Apr 2021
    Location
    Boras
    Posts
    32
    Rep Power
    7

    Re: Impossible to get smtp to work [Canon C351]

    Thanks for the input! 🙏👍

    Initialize all data seems like a good start. Do I follow these steps? Initializing All Data/Settings

    I have tried both SMTP ports 25 and 587 (changed in the service menu).

    Will check the Network TLS settings, not sure I did that.

    A firmware update would be nice, just to be sure (there’s usually a reason firmare updates get released).

  9. #9
    Senior Tech 100+ Posts Hart's Avatar
    Join Date
    Feb 2024
    Location
    Boulevard Périphérique
    Posts
    113
    Rep Power
    7

    Re: Impossible to get smtp to work [Canon C351]

    Sometimes you need to use the port 465 (SMTP SSL/TLS) instead of 587 (SMTP STARTTLS)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Get the Android App
click or scan for the Copytechnet Mobile App

-= -= -= -= -=


IDrive Remote Backup

Lunarpages Internet Solutions

Advertise on Copytechnet

Your Link Here